# CVE-2023-47130: Unsafe deserialization of user data in yiisoft/yii

> An attacker can achieve remote code execution by exploiting unsafe deserialization of user input in the Yii PHP framework.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2023
- **Updated:** 14 Aug 2024
- **Also known as:** GHSA-mw2w-2hj2-fg8q

## What is CVE-2023-47130?

CVE-2023-47130 is a high-severity unsafe deserialization vulnerability in yiisoft yii, published on 14 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Yii is an open source PHP web framework. yiisoft/yii before version 1.1.29 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. An attacker may leverage this vulnerability to compromise the host system. A fix has been developed for the 1.1.29 release. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-47130?

2 open source packages ship an affected version, including yiisoft/yii. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii` | Packagist | All versions | 1.1.29 |
| `yiisoft/yii` | Packagist | All versions | 1.1.29 |

Products: Yiiframework Yii.

## How do I fix CVE-2023-47130?

Upgrade yiisoft/yii to 1.1.29 or later.

## Is CVE-2023-47130 being exploited?

There is no known exploitation of CVE-2023-47130 in the wild and no public exploit code.

## Other vulnerabilities in yiisoft yii

- [CVE-2024-58136](https://insights.sbomify.com/CVE-2024-58136/): Yiiframework Yii Improper Protection of Alternate Path (critical 9.0, exploited in the wild)
- [CVE-2015-5467](https://insights.sbomify.com/CVE-2015-5467/): Yii2 allows attackers to execute any local .php file via a relative path in the view parameter (critical 9.8)
- [CVE-2023-26750](https://insights.sbomify.com/CVE-2023-26750/): SQL injection in n/a (critical 9.8)
- [CVE-2018-7269](https://insights.sbomify.com/CVE-2018-7269/): Yii SQL injection vulnerability (critical 9.8)
- [CVE-2018-8073](https://insights.sbomify.com/CVE-2018-8073/): yii2-redis Potential Remote code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47130 and fix it if it is affected.

What it is: CVE-2023-47130 is a high-severity unsafe deserialization vulnerability in yiisoft yii, published on 14 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-47130 in the wild and no public exploit code.

Affected packages and fixed versions:
- yiisoft/yii (Packagist): affected all versions; fixed in 1.1.29
- yiisoft/yii (Packagist): affected all versions; fixed in 1.1.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47130/ (Markdown: https://insights.sbomify.com/CVE-2023-47130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47130
- OSV: https://osv.dev/vulnerability/CVE-2023-47130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47130/
Summaries are generated and may contain mistakes; the official description above is the record.
