# CVE-2023-47204: transmute-core unsafe YAML deserialization vulnerability

> Attackers can execute arbitrary Python code via unsafe YAML deserialization in the transmute-core library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Nov 2023
- **Updated:** 6 Sep 2024
- **Also known as:** GHSA-w9cp-3x79-2p8p, PYSEC-2023-223

## What is CVE-2023-47204?

CVE-2023-47204 is a critical unsafe deserialization vulnerability in n/a, published on 2 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unsafe YAML deserialization in yaml.Loader in transmute-core before 1.13.5 allows attackers to execute arbitrary Python code.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-47204?

3 open source packages ship an affected version, including transmute-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `transmute-core` | PyPI | All versions | 1.13.5 |
| `transmute-core` | PyPI | All versions | 1.13.5 |
| `transmute-core` | PyPI | All versions | 1.13.5 |

Products: Toumorokoshi Transmute-Core.

## How do I fix CVE-2023-47204?

Upgrade transmute-core to 1.13.5 or later.

## Is CVE-2023-47204 being exploited?

There is no known exploitation of CVE-2023-47204 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47204 and fix it if it is affected.

What it is: CVE-2023-47204 is a critical unsafe deserialization vulnerability in n/a, published on 2 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-47204 in the wild and no public exploit code.

Affected packages and fixed versions:
- transmute-core (PyPI): affected all versions; fixed in 1.13.5
- transmute-core (PyPI): affected all versions; fixed in 1.13.5
- transmute-core (PyPI): affected all versions; fixed in 1.13.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47204/ (Markdown: https://insights.sbomify.com/CVE-2023-47204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47204
- OSV: https://osv.dev/vulnerability/CVE-2023-47204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47204/
Summaries are generated and may contain mistakes; the official description above is the record.
