CVE-2023-47248 PyArrow, PyArrow: Arbitrary code execution when loading a malicious data file
Attackers can execute arbitrary code by tricking applications into reading malicious Arrow IPC, Feather, or Parquet files using PyArrow.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-47248?
CVE-2023-47248 is a critical unsafe deserialization vulnerability in Apache Software Foundation PyArrow, published on 9 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files).
This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings.
It is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon.
If it is not possible to upgrade, we provide a separate package `pyarrow-hotfix` that disables the vulnerability on older PyArrow versions. See https://pypi.org/project/pyarrow-hotfix/ for instructions.
Weakness: CWE-502
Which versions are affected by CVE-2023-47248?
3 open source packages ship an affected version, including pyarrow. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pyarrow PyPI | From 0.14.0 | 14.0.1 |
pyarrow PyPI | From 0.14.0 | 14.0.1 |
pyarrow PyPI | From 0.14.0 | 14.0.1 |
Linux distribution packages (2)
python-geopandas openSUSE:Tumbleweed | All versions | 1.1.4-1.1 |
python-pandas openSUSE:Tumbleweed | All versions | 3.0.3-1.2 |
Products include Apache Pyarrow.
How do I fix CVE-2023-47248?
Upgrade pyarrow to 14.0.1 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2023-47248 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47248 exists.
Public exploit code: 1 Nuclei template and 1 proofs of concept on GitHub.
Sources
Also known as CLSA-2026-1778805964, ECHO-3d97-fb2d-213d, GHSA-5wvp-7f3h-6wmm, PYSEC-2023-238, ROOT-APP-PYPI-CVE-2023-47248, openSUSE-SU-2024:13431-1 and 4 more.