{"answers":{"affected":"3 open source packages ship an affected version, including pyarrow. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47248 exists.","fix":"Upgrade pyarrow to 14.0.1 or later.","what":"CVE-2023-47248 is a critical unsafe deserialization vulnerability in Apache Software Foundation PyArrow, published on 9 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-47248 and fix it if it is affected.\n\nWhat it is: CVE-2023-47248 is a critical unsafe deserialization vulnerability in Apache Software Foundation PyArrow, published on 9 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47248 exists.\n\nAffected packages and fixed versions:\n- pyarrow (PyPI): affected from 0.14.0; fixed in 14.0.1\n- pyarrow (PyPI): affected from 0.14.0; fixed in 14.0.1\n- pyarrow (PyPI): affected from 0.14.0; fixed in 14.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-47248/ (Markdown: https://insights.sbomify.com/CVE-2023-47248/index.md)","id":"CVE-2023-47248","markdown":"https://insights.sbomify.com/CVE-2023-47248/index.md","name":"CVE-2023-47248","record":{"aliases":["CLSA-2026-1778805964","ECHO-3d97-fb2d-213d","GHSA-5wvp-7f3h-6wmm","PYSEC-2023-238","ROOT-APP-PYPI-CVE-2023-47248","openSUSE-SU-2024:13431-1","openSUSE-SU-2024:13460-1","openSUSE-SU-2024:13480-1","openSUSE-SU-2026:11341-1","openSUSE-SU-2026:11616-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python data library","requires_auth":"none","summary":"Attackers can execute arbitrary code by tricking applications into reading malicious Arrow IPC, Feather, or Parquet files using PyArrow.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"pyarrow","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files).\n\nThis vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings.\n\nIt is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon.\n\nIf it is not possible to upgrade, we provide a separate package `pyarrow-hotfix` that disables the vulnerability on older PyArrow versions. See  https://pypi.org/project/pyarrow-hotfix/  for instructions.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2025-12-27","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":1,"refs":[{"date":"2025-12-27T17:14:15Z","kind":"github_poc","ref":"https://github.com/Prodigysec/pyarrow-CVE-2023-47248","stars":0,"title":"Repo containing pyarrow 14.0.0, vulnerable to RCE - CVE-2023-47248"},{"date":null,"kind":"nuclei","ref":"http/cves/2023/CVE-2023-47248.yaml","stars":null,"title":"PyArrow Flight RPC - Remote Code Execution"}],"tier":"weaponised"},"has_fix":true,"headline":"PyArrow, PyArrow: Arbitrary code execution when loading a malicious data file","id":"CVE-2023-47248","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2023"},"n_packages":5,"n_references":6,"next":{"headline":"Memory corruption in n/a","id":"CVE-2023-47249"},"packages":[{"ecosystem":"PyPI","fixed":["14.0.1"],"introduced":["0.14.0"],"last_affected":[],"package":"pyarrow","purl":null,"source":"GHSA-5wvp-7f3h-6wmm"},{"ecosystem":"PyPI","fixed":["14.0.1"],"introduced":["0.14.0"],"last_affected":[],"package":"pyarrow","purl":"pkg:pypi/pyarrow","source":"GHSA-5wvp-7f3h-6wmm"},{"ecosystem":"PyPI","fixed":["14.0.1"],"introduced":["0.14.0"],"last_affected":[],"package":"pyarrow","purl":"pkg:pypi/pyarrow","source":"PYSEC-2023-238"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.1.4-1.1"],"introduced":["0"],"last_affected":[],"package":"python-geopandas","purl":"pkg:rpm/opensuse/python-geopandas\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11616-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.0.3-1.2"],"introduced":["0"],"last_affected":[],"package":"python-pandas","purl":"pkg:rpm/opensuse/python-pandas\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11341-1"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2023-47247"},"products":["PyArrow"],"published":"2023-11-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary code by tricking applications into reading malicious Arrow IPC, Feather, or Parquet files using PyArrow.","url":"https://insights.sbomify.com/CVE-2023-47248/"}