# CVE-2023-47248: PyArrow, PyArrow: Arbitrary code execution when loading a malicious data file

> Attackers can execute arbitrary code by tricking applications into reading malicious Arrow IPC, Feather, or Parquet files using PyArrow.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2023
- **Updated:** 13 Feb 2025
- **Also known as:** CLSA-2026-1778805964, ECHO-3d97-fb2d-213d, GHSA-5wvp-7f3h-6wmm, PYSEC-2023-238, ROOT-APP-PYPI-CVE-2023-47248, openSUSE-SU-2024:13431-1, openSUSE-SU-2024:13460-1, openSUSE-SU-2024:13480-1, openSUSE-SU-2026:11341-1, openSUSE-SU-2026:11616-1

## What is CVE-2023-47248?

CVE-2023-47248 is a critical unsafe deserialization vulnerability in Apache Software Foundation PyArrow, published on 9 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files).

This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings.

It is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon.

If it is not possible to upgrade, we provide a separate package `pyarrow-hotfix` that disables the vulnerability on older PyArrow versions. See  https://pypi.org/project/pyarrow-hotfix/  for instructions.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-47248?

3 open source packages ship an affected version, including pyarrow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyarrow` | PyPI | From 0.14.0 | 14.0.1 |
| `pyarrow` | PyPI | From 0.14.0 | 14.0.1 |
| `pyarrow` | PyPI | From 0.14.0 | 14.0.1 |
| `python-geopandas` | openSUSE:Tumbleweed | All versions | 1.1.4-1.1 |
| `python-pandas` | openSUSE:Tumbleweed | All versions | 3.0.3-1.2 |

Products: Apache Pyarrow.

## How do I fix CVE-2023-47248?

Upgrade pyarrow to 14.0.1 or later.

## Is CVE-2023-47248 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47248 exists.

Public exploit code:

- Repo containing pyarrow 14.0.0, vulnerable to RCE - CVE-2023-47248 (github_poc): https://github.com/Prodigysec/pyarrow-CVE-2023-47248
- PyArrow Flight RPC - Remote Code Execution (nuclei): http/cves/2023/CVE-2023-47248.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47248 and fix it if it is affected.

What it is: CVE-2023-47248 is a critical unsafe deserialization vulnerability in Apache Software Foundation PyArrow, published on 9 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47248 exists.

Affected packages and fixed versions:
- pyarrow (PyPI): affected from 0.14.0; fixed in 14.0.1
- pyarrow (PyPI): affected from 0.14.0; fixed in 14.0.1
- pyarrow (PyPI): affected from 0.14.0; fixed in 14.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47248/ (Markdown: https://insights.sbomify.com/CVE-2023-47248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47248
- OSV: https://osv.dev/vulnerability/CVE-2023-47248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47248/
Summaries are generated and may contain mistakes; the official description above is the record.
