CVE-2023-47258 Cross-site scripting in n/a
An attacker can inject malicious scripts via the Markdown formatter in Redmine, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-47258?
CVE-2023-47258 is a medium-severity cross-site scripting vulnerability in Redmine Redmine, published on 5 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Redmine before 4.2.11 and 5.0.x before 5.0.6 allows XSS in a Markdown formatter.
Weakness: CWE-79
Which versions are affected by CVE-2023-47258?
1 open source package ship an affected version, including redmine. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
redmine Bitnami | All versions | 4.2.11, 5.0.6 |
Products include Redmine Redmine.
How do I fix CVE-2023-47258?
Upgrade redmine to a fixed version for your release line: 4.2.11 or 5.0.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-47258 being exploited?
There is no known exploitation of CVE-2023-47258 in the wild and no public exploit code.
Other vulnerabilities in Redmine Redmine
Sources
Also known as BIT-redmine-2023-47258, DEBIAN-CVE-2023-47258, GHSA-rmx7-grxr-fhm3, UBUNTU-CVE-2023-47258.