CVE-2023-47265 Apache Airflow: DAG Params alllow to embed unchecked Javascript
A stored XSS vulnerability in Apache Airflow allows DAG authors to inject JavaScript that executes in other users' browsers, potentially misleading them.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-47265?
CVE-2023-47265 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 21 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Apache Airflow, versions 2.6.0 through 2.7.3 has a stored XSS vulnerability that allows a DAG author to add an unbounded and not-sanitized javascript in the parameter description field of the DAG. This Javascript can be executed on the client side of any of the user who looks at the tasks in the browser sandbox. While this issue does not allow to exit the browser sandbox or manipulation of the server-side data - more than the DAG author already has, it allows to modify what the user looking at the DAG details sees in the browser - which opens up all kinds of possibilities of misleading other users.
Users of Apache Airflow are recommended to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability
Weakness: CWE-79
Which versions are affected by CVE-2023-47265?
4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-airflow PyPI | From 2.6.0 | 2.8.0b1 |
apache-airflow PyPI | From 2.6.0 | 2.8.0b1 |
apache-airflow PyPI | From 2.6.0 | 2.8.0b1 |
airflow Bitnami | From 2.6.0 | 2.7.4 |
Products include Apache Airflow.
How do I fix CVE-2023-47265?
Upgrade apache-airflow to 2.8.0b1 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-47265 being exploited?
There is no known exploitation of CVE-2023-47265 in the wild and no public exploit code.
Other vulnerabilities in Apache Airflow
- CVE-2020-13927 Apache Airflow's Experimental API Authentication Bypass
- CVE-2020-11978 Apache Airflow Command Injection
- CVE-2026-33264 Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()
- CVE-2023-25754 Apache Airflow: Privilege escalation using airflow logs
- CVE-2023-22884 Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow
Sources
Also known as BIT-airflow-2023-47265, ECHO-d135-ddb5-9664, GHSA-pxch-wr7m-rwxj, PYSEC-2023-264.