CVE-2023-47272 Cross-site scripting in n/a
Attackers can execute arbitrary scripts in victim browsers via malicious email headers, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-47272?
CVE-2023-47272 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 5 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Roundcube 1.5.x before 1.5.6 and 1.6.x before 1.6.5 allows XSS via a Content-Type or Content-Disposition header (used for attachment preview or download).
Weakness: CWE-79
Which versions are affected by CVE-2023-47272?
1 open source package ship an affected version, including roundcube. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
roundcube Bitnami | From 1.5.0 | 1.5.6, 1.6.5 |
Linux distribution packages (3)
roundcubemail SUSE:Package Hub 15 SP5 | All versions | 1.6.7-bp155.2.9.1 |
roundcubemail openSUSE:Leap 15.5 | All versions | 1.6.7-bp155.2.9.1 |
roundcubemail openSUSE:Tumbleweed | All versions | 1.6.5-1.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Roundcube Webmail.
How do I fix CVE-2023-47272?
Upgrade roundcube to a fixed version for your release line: 1.5.6 or 1.6.5.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-47272 being exploited?
There is no known exploitation of CVE-2023-47272 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-roundcube-2023-47272, DEBIAN-CVE-2023-47272, DLA-3683-1, DSA-5572-1, GHSA-q2wj-pp48-fpgj, UBUNTU-CVE-2023-47272 and 2 more.