{"answers":{"affected":"2 open source packages ship an affected version, including swiftyedit/swiftyedit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-47350 in the wild and no public exploit code.","fix":"Upgrade swiftyedit/swiftyedit to 1.2.0 or later.","what":"CVE-2023-47350 is a high-severity vulnerability in n/a, published on 22 Nov 2023."},"fix_prompt":"Check this codebase for CVE-2023-47350 and fix it if it is affected.\n\nWhat it is: CVE-2023-47350 is a high-severity vulnerability in n/a, published on 22 Nov 2023. \nExploitation: There is no known exploitation of CVE-2023-47350 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- swiftyedit/swiftyedit (Packagist): affected all versions; fixed in 1.2.0\n- swiftyedit/swiftyedit (Packagist): affected all versions; fixed in 1.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-47350/ (Markdown: https://insights.sbomify.com/CVE-2023-47350/index.md)","id":"CVE-2023-47350","markdown":"https://insights.sbomify.com/CVE-2023-47350/index.md","name":"CVE-2023-47350","record":{"aliases":["GHSA-2492-xxqf-6h78"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"swiftyedit","vendor":"swiftyedit"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-Site Request Forgery (CSRF) vulnerability in SwiftyEdit Content Management System prior to v1.2.0, allows remote attackers to escalate privileges via the user password update functionality.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross Site Request Forgery in SwiftyEdit","id":"CVE-2023-47350","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Hardcoded credentials in n/a","id":"CVE-2023-47352"},"packages":[{"ecosystem":"Packagist","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"swiftyedit/swiftyedit","purl":null,"source":"GHSA-2492-xxqf-6h78"},{"ecosystem":"Packagist","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"swiftyedit/swiftyedit","purl":"pkg:composer/swiftyedit/swiftyedit","source":"GHSA-2492-xxqf-6h78"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2023-47347"},"products":["n/a"],"published":"2023-11-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-26","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2023-47350/"}