CVE-2023-47379 Microweber Cross-site Scripting vulnerability

Medium 5.4 Published Updated

Attackers can inject malicious scripts via profile picture uploads in Microweber CMS, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-47379?

CVE-2023-47379 is a medium-severity cross-site scripting vulnerability in Microweber Microweber, published on 8 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Microweber CMS version 2.0.1 is vulnerable to stored Cross Site Scripting (XSS) via the profile picture file upload functionality.

Weakness: CWE-79

Which versions are affected by CVE-2023-47379?

2 open source packages ship an affected version, including microweber/microweber. It affects 1 product.

PackageAffectedFixed in
microweber/microweber PackagistAll versions2.0.3
microweber/microweber PackagistAll versions2.0.3

Products include Microweber Microweber.

How do I fix CVE-2023-47379?

Upgrade microweber/microweber to 2.0.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-47379 being exploited?

There is no known exploitation of CVE-2023-47379 in the wild and no public exploit code.

All Microweber Microweber vulnerabilities

Sources

Also known as GHSA-jmwm-w2rm-prv9.

Is CVE-2023-47379 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free