# CVE-2023-4759: Improper handling of case insensitive filesystems in Eclipse JGit allows arbitrary file write

> Attackers can overwrite arbitrary files via crafted symlinks on case-insensitive filesystems, potentially leading to remote code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Sep 2023
- **Updated:** 2 Aug 2024
- **Also known as:** CLSA-2026-1771373384, CVE-2024-41807, DEBIAN-CVE-2023-4759, GHSA-3p86-9955-h393, MINI-6c9h-6q4x-wrvf, OESA-2023-1995, ROOT-APP-MAVEN-CVE-2023-4759, SUSE-SU-2024:0057-1, UBUNTU-CVE-2023-4759, openSUSE-SU-2024:13312-1

## What is CVE-2023-4759?

CVE-2023-4759 is a high-severity path traversal vulnerability in Eclipse JGit, published on 12 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Arbitrary File Overwrite in Eclipse JGit <= 6.6.0

In Eclipse JGit, all versions <= 6.6.0.202305301015-r, a symbolic link present in a specially crafted git repository can be used to write a file to locations outside the working tree when this repository is cloned with JGit to a case-insensitive filesystem, or when a checkout from a clone of such a repository is performed on a case-insensitive filesystem.

This can happen on checkout (DirCacheCheckout), merge (ResolveMerger via its WorkingTreeUpdater), pull (PullCommand using merge), and when applying a patch (PatchApplier). This can be exploited for remote code execution (RCE), for instance if the file written outside the working tree is a git filter that gets executed on a subsequent git command.

The issue occurs only on case-insensitive filesystems, like the default filesystems on Windows and macOS. The user performing the clone or checkout must have the rights to create symbolic links for the problem to occur, and symbolic links must be enabled in the git configuration.

Setting git configuration option core.symlinks = false before checking out avoids the problem.

The issue was fixed in Eclipse JGit version 6.6.1.202309021850-r and 6.7.0.202309050840-r, available via  Maven Central https://repo1.maven.org/maven2/org/eclipse/jgit/  and  repo.eclipse.org https://repo.eclipse.org/content/repositories/jgit-releases/ . A backport is available in 5.13.3 starting from  5.13.3.202401111512-r.

The JGit maintainers would like to thank RyotaK for finding and reporting this issue.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2023-4759?

4 open source packages ship an affected version, including org.eclipse.jgit:org.eclipse.jgit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jgit:org.eclipse.jgit` | Maven | All versions | 5.13.3.202401111512-r |
| `org.eclipse.jgit:org.eclipse.jgit` | Maven | All versions | 5.13.3.202401111512-r |
| `org.eclipse.jgit:org.eclipse.jgit` | Maven | From 6.0.0.202111291000-r | 6.6.1.202309021850-r |
| `org.eclipse.jgit:org.eclipse.jgit` | Maven | From 6.0.0.202111291000-r | 6.6.1.202309021850-r |
| `jsch` | SUSE:Enterprise Storage 7.1 | All versions | 0.2.9-150200.11.10.1 |
| `jsch` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 0.2.9-150200.11.10.1 |
| `jsch` | SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 0.2.9-150200.11.10.1 |
| `jsch` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 0.2.9-150200.11.10.1 |
| `jsch` | SUSE:Linux Enterprise Module for Development Tools 15 SP4 | All versions | 0.2.9-150200.11.10.1 |
| `jsch` | SUSE:Linux Enterprise Module for Development Tools 15 SP5 | All versions | 0.2.9-150200.11.10.1 |
| `jsch` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 0.2.9-150200.11.10.1 |
| `jsch` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 0.2.9-150200.11.10.1 |
| `jsch` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 0.2.9-150200.11.10.1 |
| `jsch` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 0.2.9-150200.11.10.1 |
| `jsch` | SUSE:Manager Server Module 4.3 | All versions | 0.2.9-150200.11.10.1 |
| `eclipse-jgit` | openSUSE:Leap 15.4 | All versions | 5.11.0-150200.3.15.2 |
| `jgit` | openSUSE:Leap 15.4 | All versions | 5.11.0-150200.3.15.2 |
| `jsch` | openSUSE:Leap 15.4 | All versions | 0.2.9-150200.11.10.1 |
| `eclipse-jgit` | openSUSE:Leap 15.5 | All versions | 5.11.0-150200.3.15.2 |
| `jsch` | openSUSE:Leap 15.5 | All versions | 0.2.9-150200.11.10.1 |
| `eclipse-jgit` | openSUSE:Tumbleweed | All versions | 5.11.0-9.1 |

Products: Eclipse Jgit.

## How do I fix CVE-2023-4759?

Upgrade org.eclipse.jgit:org.eclipse.jgit to a fixed version for your release line: 5.13.3.202401111512-r or 6.6.1.202309021850-r.

## Is CVE-2023-4759 being exploited?

There is no known exploitation of CVE-2023-4759 in the wild and no public exploit code.

## Other vulnerabilities in Eclipse JGit

- [CVE-2025-4949](https://insights.sbomify.com/CVE-2025-4949/): XXE vulnerability in Eclipse JGit (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-4759 and fix it if it is affected.

What it is: CVE-2023-4759 is a high-severity path traversal vulnerability in Eclipse JGit, published on 12 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-4759 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jgit:org.eclipse.jgit (Maven): affected all versions; fixed in 5.13.3.202401111512-r
- org.eclipse.jgit:org.eclipse.jgit (Maven): affected all versions; fixed in 5.13.3.202401111512-r
- org.eclipse.jgit:org.eclipse.jgit (Maven): affected from 6.0.0.202111291000-r; fixed in 6.6.1.202309021850-r
- org.eclipse.jgit:org.eclipse.jgit (Maven): affected from 6.0.0.202111291000-r; fixed in 6.6.1.202309021850-r

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-4759/ (Markdown: https://insights.sbomify.com/CVE-2023-4759/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-4759
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-4759
- OSV: https://osv.dev/vulnerability/CVE-2023-4759

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-4759/
Summaries are generated and may contain mistakes; the official description above is the record.
