{"answers":{"affected":"4 open source packages ship an affected version, including duncanmcclean/guest-entries and doublethreedigital/guest-entries. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-47621 in the wild and no public exploit code.","fix":"Upgrade duncanmcclean/guest-entries to 3.1.2 or later.","what":"CVE-2023-47621 is a high-severity vulnerability in duncanmcclean guest-entries, published on 13 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-47621 and fix it if it is affected.\n\nWhat it is: CVE-2023-47621 is a high-severity vulnerability in duncanmcclean guest-entries, published on 13 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-47621 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- duncanmcclean/guest-entries (Packagist): affected all versions; fixed in 3.1.2\n- duncanmcclean/guest-entries (Packagist): affected all versions; fixed in 3.1.2\n- doublethreedigital/guest-entries (Packagist): affected all versions; fixed in 3.1.2\n- doublethreedigital/guest-entries (Packagist): affected all versions; fixed in 3.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-47621/ (Markdown: https://insights.sbomify.com/CVE-2023-47621/index.md)","id":"CVE-2023-47621","markdown":"https://insights.sbomify.com/CVE-2023-47621/index.md","name":"CVE-2023-47621","record":{"aliases":["GHSA-rw82-mhmx-grmj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP guest entries library","requires_auth":"low_privilege","summary":"Authenticated users can upload PHP files to execute arbitrary code on the server due to missing file type restrictions in the guest-entries library.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"guest_entries","vendor":"duncanmcclean"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"Guest Entries is a php library which allows users to create, update \u0026 delete entries from the front-end of a site. In affected versions the file uploads feature did not prevent the upload of PHP files. This may lead to code execution on the server by authenticated users. This vulnerability is fixed in v3.1.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote code execution via file uploads in guest-entries","id":"CVE-2023-47621","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"file_upload","year":"2023"},"n_packages":4,"n_references":2,"next":{"headline":"iTop vulnerable to XSS vulnerability in dashlet refresh","id":"CVE-2023-47622"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"doublethreedigital/guest-entries","purl":null,"source":"GHSA-rw82-mhmx-grmj"},{"ecosystem":"Packagist","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"doublethreedigital/guest-entries","purl":"pkg:composer/doublethreedigital/guest-entries","source":"GHSA-rw82-mhmx-grmj"},{"ecosystem":"Packagist","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"duncanmcclean/guest-entries","purl":null,"source":"GHSA-rw82-mhmx-grmj"},{"ecosystem":"Packagist","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"duncanmcclean/guest-entries","purl":"pkg:composer/duncanmcclean/guest-entries","source":"GHSA-rw82-mhmx-grmj"}],"prev":{"headline":"Scrypted reflected Cross-site Scripting vulnerability","id":"CVE-2023-47620"},"products":["guest-entries"],"published":"2023-11-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-03","vendors":["duncanmcclean"]},"summary":"Authenticated users can upload PHP files to execute arbitrary code on the server due to missing file type restrictions in the guest-entries library.","url":"https://insights.sbomify.com/CVE-2023-47621/"}