# CVE-2023-47628: Session Expiration Misconfiguration in datahub

> Attackers can hijack user accounts indefinitely if session cookies are leaked, as DataHub fails to set cookie expiration times.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 Nov 2023
- **Updated:** 3 Sep 2024
- **Also known as:** GHSA-75p8-rgh2-r9mx

## What is CVE-2023-47628?

CVE-2023-47628 is a medium-severity vulnerability in datahub-project datahub, published on 14 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

DataHub is an open-source metadata platform. DataHub Frontend's sessions are configured using Play Framework's default settings for stateless session which do not set an expiration time for a cookie. Due to this, if a session cookie were ever leaked, it would be valid forever. DataHub uses a stateless session cookie that is not invalidated on logout, it is just removed from the browser forcing the user to login again. However, if an attacker extracted a cookie from an authenticated user it would continue to be valid as there is no validation on a time window the session token is valid for due to a combination of the usage of LegacyCookiesModule from Play Framework and using default settings which do not set an expiration time. All DataHub instances prior to the patch that have removed the datahub user, but not the default policies applying to that user are affected. Users are advised to update to version 0.12.1 which addresses the issue. There are no known workarounds for this vulnerability.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2023-47628?

It affects 1 product.


Products: Datahub Project Datahub.

## How do I fix CVE-2023-47628?

No fix has been published for CVE-2023-47628 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-47628 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47628 exists.

## Other vulnerabilities in datahub-project datahub

- [CVE-2024-22409](https://insights.sbomify.com/CVE-2024-22409/): Default Privileges allow for high level operations for low privileged users in datahub (high 7.5)
- [CVE-2023-25558](https://insights.sbomify.com/CVE-2023-25558/): Deserialization of untrusted data in DataHub (high 7.5)
- [CVE-2023-47629](https://insights.sbomify.com/CVE-2023-47629/): Privilege escalation through email sign-up in datahub (high 7.1)
- [CVE-2023-47640](https://insights.sbomify.com/CVE-2023-47640/): Insecure Use of HMAC-SHA1 For Session Signing in datahub (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47628 and fix it if it is affected.

What it is: CVE-2023-47628 is a medium-severity vulnerability in datahub-project datahub, published on 14 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47628 exists.

Affected product: datahub-project datahub. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47628/ (Markdown: https://insights.sbomify.com/CVE-2023-47628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47628
- OSV: https://osv.dev/vulnerability/CVE-2023-47628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47628/
Summaries are generated and may contain mistakes; the official description above is the record.
