# CVE-2023-47630: Attacker can cause Kyverno user to unintentionally consume insecure image

> Attackers compromising registries can serve malicious images to Kyverno users, enabling code execution and privilege escalation.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Nov 2023
- **Updated:** 27 Nov 2024
- **Also known as:** BIT-kyverno-2023-47630, CLEANSTART-2025-NY44240, CLEANSTART-2026-LU55678, GHSA-3hfq-cx9j-923w, GO-2023-2340

## What is CVE-2023-47630?

CVE-2023-47630 is a high-severity vulnerability in kyverno, published on 14 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Kyverno is a policy engine designed for Kubernetes. An issue was found in Kyverno that allowed an attacker to control the digest of images used by Kyverno users. The issue would require the attacker to compromise the registry that the Kyverno users fetch their images from. The attacker could then return an vulnerable image to the the user and leverage that to further escalate their position. As such, the attacker would need to know which images the Kyverno user consumes and know of one of multiple exploitable vulnerabilities in previous digests of the images. Alternatively, if the attacker has compromised the registry, they could craft a malicious image with a different digest with intentionally placed vulnerabilities and deliver the image to the user.  Users pulling their images by digests and from trusted registries are not impacted by this vulnerability. There is no evidence of this being exploited in the wild. The issue has been patched in 1.10.5. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2023-47630?

4 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | All versions | 1.10.5 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.10.5 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.10.5 |
| `kyverno` | Bitnami | All versions | 1.10.5 |

Products: Kyverno Kyverno.

## How do I fix CVE-2023-47630?

Upgrade github.com/kyverno/kyverno to 1.10.5 or later.

## Is CVE-2023-47630 being exploited?

There is no known exploitation of CVE-2023-47630 in the wild and no public exploit code.

## Other vulnerabilities in kyverno

- [CVE-2026-22039](https://insights.sbomify.com/CVE-2026-22039/): Kyverno Cross-Namespace Privilege Escalation via Policy apiCall (critical 10.0)
- [CVE-2026-4789](https://insights.sbomify.com/CVE-2026-4789/): CVE-2026-4789 (critical 9.8)
- [CVE-2025-46342](https://insights.sbomify.com/CVE-2025-46342/): Kyverno vulnerable to bypass of policy rules that use namespace selectors in match statements (high 8.6)
- [CVE-2026-41323](https://insights.sbomify.com/CVE-2026-41323/): Kyverno: ServiceAccount token leaked to external servers via apiCall service URL (high 8.1)
- [CVE-2026-40868](https://insights.sbomify.com/CVE-2026-40868/): kyverno apicall servicecall implicit bearer token injection leaks kyverno serviceaccount token (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47630 and fix it if it is affected.

What it is: CVE-2023-47630 is a high-severity vulnerability in kyverno, published on 14 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-47630 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.10.5
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.10.5
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.10.5
- kyverno (Bitnami): affected all versions; fixed in 1.10.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47630/ (Markdown: https://insights.sbomify.com/CVE-2023-47630/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47630
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47630
- OSV: https://osv.dev/vulnerability/CVE-2023-47630

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47630/
Summaries are generated and may contain mistakes; the official description above is the record.
