# CVE-2023-47631: vantage6 Node accepts non-whitelisted algorithms from malicious server

> A malicious server can bypass algorithm whitelisting in vantage6 nodes by setting a fake parent_id, allowing execution of unauthorized code.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-vc3v-ppc7-v486, PYSEC-2023-303, PYSEC-2023-304

## What is CVE-2023-47631?

CVE-2023-47631 is a high-severity vulnerability in vantage6, published on 14 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

vantage6 is a framework to manage and deploy privacy enhancing technologies like Federated Learning (FL) and Multi-Party Computation (MPC). In affected versions a node does not check if an image is allowed to run if a `parent_id` is set. A malicious party that breaches the server may modify it to set a fake `parent_id` and send a task of a non-whitelisted algorithm. The node will then execute it because the `parent_id` that is set prevents checks from being run. This impacts all servers that are breached by an expert user. This vulnerability has been patched in version 4.1.2. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2023-47631?

6 open source packages ship an affected version, including vantage6-node and vantage6-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6-node` | PyPI | All versions | 4.1.2 |
| `vantage6-node` | PyPI | All versions | 4.1.2 |
| `vantage6-node` | PyPI | All versions | 4.1.2 |
| `vantage6-server` | PyPI | All versions | 4.1.2 |
| `vantage6-server` | PyPI | All versions | 4.1.2 |
| `vantage6-server` | PyPI | All versions | 4.1.2 |

Products: Vantage6 Vantage6.

## How do I fix CVE-2023-47631?

Upgrade vantage6-node to 4.1.2 or later.

## Is CVE-2023-47631 being exploited?

There is no known exploitation of CVE-2023-47631 in the wild and no public exploit code.

## Other vulnerabilities in vantage6

- [CVE-2024-21649](https://insights.sbomify.com/CVE-2024-21649/): Remote code execution (high 8.8)
- [CVE-2023-23929](https://insights.sbomify.com/CVE-2023-23929/): Refresh tokens do not expire in Vantage6 (high 8.8)
- [CVE-2024-21653](https://insights.sbomify.com/CVE-2024-21653/): vantage6 insecure SSH configuration for node and server containers (medium 6.5)
- [CVE-2023-22738](https://insights.sbomify.com/CVE-2023-22738/): Improper Preservation of Permissions in vantage6 (medium 6.3)
- [CVE-2023-23930](https://insights.sbomify.com/CVE-2023-23930/): vantage6's Pickle serialization is insecure (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47631 and fix it if it is affected.

What it is: CVE-2023-47631 is a high-severity vulnerability in vantage6, published on 14 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-47631 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6-node (PyPI): affected all versions; fixed in 4.1.2
- vantage6-node (PyPI): affected all versions; fixed in 4.1.2
- vantage6-node (PyPI): affected all versions; fixed in 4.1.2
- vantage6-server (PyPI): affected all versions; fixed in 4.1.2
- vantage6-server (PyPI): affected all versions; fixed in 4.1.2
- vantage6-server (PyPI): affected all versions; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47631/ (Markdown: https://insights.sbomify.com/CVE-2023-47631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47631
- OSV: https://osv.dev/vulnerability/CVE-2023-47631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47631/
Summaries are generated and may contain mistakes; the official description above is the record.
