{"answers":{"affected":"4 open source packages ship an affected version, including decidim. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-47634 in the wild and no public exploit code.","fix":"Upgrade decidim to a fixed version for your release line: 0.26.9 or 0.27.5.","what":"CVE-2023-47634 is a low-severity vulnerability in decidim, published on 20 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-47634 and fix it if it is affected.\n\nWhat it is: CVE-2023-47634 is a low-severity vulnerability in decidim, published on 20 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-47634 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decidim (RubyGems): affected from 0.10.0; fixed in 0.26.9\n- decidim (RubyGems): affected from 0.10.0; fixed in 0.26.9\n- decidim (RubyGems): affected from 0.27.0; fixed in 0.27.5\n- decidim (RubyGems): affected from 0.27.0; fixed in 0.27.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-47634/ (Markdown: https://insights.sbomify.com/CVE-2023-47634/index.md)","id":"CVE-2023-47634","markdown":"https://insights.sbomify.com/CVE-2023-47634/index.md","name":"CVE-2023-47634","record":{"aliases":["GHSA-r275-j57c-7mf2"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy","requires_auth":"low_privilege","summary":"A race condition in Decidim allows users to bypass single-endorsement limits by sending parallel requests, enabling multiple endorsements for a single resource.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"decidim","vendor":"decidim"}],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"Decidim is a participatory democracy framework. Starting in version 0.10.0 and prior to versions 0.26.9, 0.27.5, and 0.28.0, a race condition in the endorsement of resources (for instance, a proposal) allows a user to make more than once endorsement. To exploit this vulnerability, the request to set an endorsement must be sent several times in parallel. Versions 0.26.9, 0.27.5, and 0.28.0 contain a patch for this issue. As a workaround, disable the Endorsement feature in the components.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Decidim has race condition in Endorsements","id":"CVE-2023-47634","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"race_condition","year":"2023"},"n_packages":4,"n_references":4,"next":{"headline":"Decidim vulnerable to possible CSRF attack at questionnaire templates preview","id":"CVE-2023-47635"},"packages":[{"ecosystem":"RubyGems","fixed":["0.26.9"],"introduced":["0.10.0"],"last_affected":[],"package":"decidim","purl":null,"source":"GHSA-r275-j57c-7mf2"},{"ecosystem":"RubyGems","fixed":["0.26.9"],"introduced":["0.10.0"],"last_affected":[],"package":"decidim","purl":"pkg:gem/decidim","source":"GHSA-r275-j57c-7mf2"},{"ecosystem":"RubyGems","fixed":["0.27.5"],"introduced":["0.27.0"],"last_affected":[],"package":"decidim","purl":null,"source":"GHSA-r275-j57c-7mf2"},{"ecosystem":"RubyGems","fixed":["0.27.5"],"introduced":["0.27.0"],"last_affected":[],"package":"decidim","purl":"pkg:gem/decidim","source":"GHSA-r275-j57c-7mf2"}],"prev":{"headline":"Uncontrolled Resource Consumption in Traefik","id":"CVE-2023-47633"},"products":["decidim"],"published":"2024-02-20","related":[{"cvss_score":9.3,"headline":"Decidim has a Cross-site scripting (XSS) vulnerability via user name field","id":"CVE-2026-23891","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":9.1,"headline":"Decidim has broken access control in templates","id":"CVE-2023-36465","kev_date_added":null,"published":"2023-10-06"},{"cvss_score":8.2,"headline":"Decidim's private data exports can lead to data leaks","id":"CVE-2025-65017","kev_date_added":null,"published":"2026-02-03"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the external link redirections","id":"CVE-2023-32693","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the processes filter","id":"CVE-2023-34089","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":7.7,"headline":"Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds","id":"CVE-2024-45594","kev_date_added":null,"published":"2024-11-13"},{"cvss_score":7.5,"headline":"Decidim amendments can be accepted or rejected by anyone","id":"CVE-2026-40869","kev_date_added":null,"published":"2026-04-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["decidim"]},"summary":"A race condition in Decidim allows users to bypass single-endorsement limits by sending parallel requests, enabling multiple endorsements for a single resource.","url":"https://insights.sbomify.com/CVE-2023-47634/"}