CVE-2023-47635 Decidim vulnerable to possible CSRF attack at questionnaire templates preview

Medium 4.5 Published Updated

Attackers can bypass CSRF checks on questionnaire template previews to access non-public information if they possess the victim's session cookie.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-47635?

CVE-2023-47635 is a medium-severity vulnerability in decidim, published on 20 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Decidim is a participatory democracy framework. Starting in version 0.23.0 and prior to versions 0.27.5 and 0.28.0, the CSRF authenticity token check is disabled for the questionnaire templates preview. The issue does not imply a serious security thread as you need to have access also to the session cookie in order to see this resource. This URL does not allow modifying the resource but it may allow attackers to gain access to information which was not meant to be public. The issue is fixed in version 0.27.5 and 0.28.0. As a workaround, disable the templates functionality or remove all available templates.

Weakness: CWE-352, CWE-918

Which versions are affected by CVE-2023-47635?

2 open source packages ship an affected version, including decidim-templates. It affects 1 product.

PackageAffectedFixed in
decidim-templates RubyGemsFrom 0.23.00.27.5
decidim-templates RubyGemsFrom 0.23.00.27.5

Products include Decidim Decidim.

How do I fix CVE-2023-47635?

Upgrade decidim-templates to 0.27.5 or later.

Is CVE-2023-47635 being exploited?

There is no known exploitation of CVE-2023-47635 in the wild and no public exploit code.

Sources

Also known as GHSA-f3qm-vfc3-jg6v.

Is CVE-2023-47635 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free