{"answers":{"affected":"2 open source packages ship an affected version, including decidim-templates. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-47635 in the wild and no public exploit code.","fix":"Upgrade decidim-templates to 0.27.5 or later.","what":"CVE-2023-47635 is a medium-severity vulnerability in decidim, published on 20 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-47635 and fix it if it is affected.\n\nWhat it is: CVE-2023-47635 is a medium-severity vulnerability in decidim, published on 20 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-47635 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decidim-templates (RubyGems): affected from 0.23.0; fixed in 0.27.5\n- decidim-templates (RubyGems): affected from 0.23.0; fixed in 0.27.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-47635/ (Markdown: https://insights.sbomify.com/CVE-2023-47635/index.md)","id":"CVE-2023-47635","markdown":"https://insights.sbomify.com/CVE-2023-47635/index.md","name":"CVE-2023-47635","record":{"aliases":["GHSA-f3qm-vfc3-jg6v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy","requires_auth":"high_privilege","summary":"Attackers can bypass CSRF checks on questionnaire template previews to access non-public information if they possess the victim's session cookie.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"decidim","vendor":"decidim"}],"cvss":{"score":4.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"},{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Decidim is a participatory democracy framework. Starting in version 0.23.0 and prior to versions 0.27.5 and 0.28.0, the CSRF authenticity token check is disabled for the questionnaire templates preview. The issue does not imply a serious security thread as you need to have access also to the session cookie in order to see this resource. This URL does not allow modifying the resource but it may allow attackers to gain access to information which was not meant to be public. The issue is fixed in version 0.27.5 and 0.28.0. As a workaround, disable the templates functionality or remove all available templates.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Decidim vulnerable to possible CSRF attack at questionnaire templates preview","id":"CVE-2023-47635","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":8,"next":{"headline":"Full Path Disclosure via re-export document in pimcore/admin-ui-classic-bundle","id":"CVE-2023-47636"},"packages":[{"ecosystem":"RubyGems","fixed":["0.27.5"],"introduced":["0.23.0"],"last_affected":[],"package":"decidim-templates","purl":null,"source":"GHSA-f3qm-vfc3-jg6v"},{"ecosystem":"RubyGems","fixed":["0.27.5"],"introduced":["0.23.0"],"last_affected":[],"package":"decidim-templates","purl":"pkg:gem/decidim-templates","source":"GHSA-f3qm-vfc3-jg6v"}],"prev":{"headline":"Decidim has race condition in Endorsements","id":"CVE-2023-47634"},"products":["decidim"],"published":"2024-02-20","related":[{"cvss_score":9.3,"headline":"Decidim has a Cross-site scripting (XSS) vulnerability via user name field","id":"CVE-2026-23891","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":9.1,"headline":"Decidim has broken access control in templates","id":"CVE-2023-36465","kev_date_added":null,"published":"2023-10-06"},{"cvss_score":8.2,"headline":"Decidim's private data exports can lead to data leaks","id":"CVE-2025-65017","kev_date_added":null,"published":"2026-02-03"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the external link redirections","id":"CVE-2023-32693","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the processes filter","id":"CVE-2023-34089","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":7.7,"headline":"Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds","id":"CVE-2024-45594","kev_date_added":null,"published":"2024-11-13"},{"cvss_score":7.5,"headline":"Decidim amendments can be accepted or rejected by anyone","id":"CVE-2026-40869","kev_date_added":null,"published":"2026-04-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-22","vendors":["decidim"]},"summary":"Attackers can bypass CSRF checks on questionnaire template previews to access non-public information if they possess the victim's session cookie.","url":"https://insights.sbomify.com/CVE-2023-47635/"}