# CVE-2023-47635: Decidim vulnerable to possible CSRF attack at questionnaire templates preview

> Attackers can bypass CSRF checks on questionnaire template previews to access non-public information if they possess the victim's session cookie.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 22 Aug 2024
- **Also known as:** GHSA-f3qm-vfc3-jg6v

## What is CVE-2023-47635?

CVE-2023-47635 is a medium-severity vulnerability in decidim, published on 20 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Decidim is a participatory democracy framework. Starting in version 0.23.0 and prior to versions 0.27.5 and 0.28.0, the CSRF authenticity token check is disabled for the questionnaire templates preview. The issue does not imply a serious security thread as you need to have access also to the session cookie in order to see this resource. This URL does not allow modifying the resource but it may allow attackers to gain access to information which was not meant to be public. The issue is fixed in version 0.27.5 and 0.28.0. As a workaround, disable the templates functionality or remove all available templates.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-47635?

2 open source packages ship an affected version, including decidim-templates. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim-templates` | RubyGems | From 0.23.0 | 0.27.5 |
| `decidim-templates` | RubyGems | From 0.23.0 | 0.27.5 |

Products: Decidim Decidim.

## How do I fix CVE-2023-47635?

Upgrade decidim-templates to 0.27.5 or later.

## Is CVE-2023-47635 being exploited?

There is no known exploitation of CVE-2023-47635 in the wild and no public exploit code.

## Other vulnerabilities in decidim

- [CVE-2026-23891](https://insights.sbomify.com/CVE-2026-23891/): Decidim has a Cross-site scripting (XSS) vulnerability via user name field (critical 9.3)
- [CVE-2023-36465](https://insights.sbomify.com/CVE-2023-36465/): Decidim has broken access control in templates (critical 9.1)
- [CVE-2025-65017](https://insights.sbomify.com/CVE-2025-65017/): Decidim's private data exports can lead to data leaks (high 8.2)
- [CVE-2023-32693](https://insights.sbomify.com/CVE-2023-32693/): Decidim Cross-site Scripting vulnerability in the external link redirections (high 8.1)
- [CVE-2023-34089](https://insights.sbomify.com/CVE-2023-34089/): Decidim Cross-site Scripting vulnerability in the processes filter (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47635 and fix it if it is affected.

What it is: CVE-2023-47635 is a medium-severity vulnerability in decidim, published on 20 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-47635 in the wild and no public exploit code.

Affected packages and fixed versions:
- decidim-templates (RubyGems): affected from 0.23.0; fixed in 0.27.5
- decidim-templates (RubyGems): affected from 0.23.0; fixed in 0.27.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47635/ (Markdown: https://insights.sbomify.com/CVE-2023-47635/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47635
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47635
- OSV: https://osv.dev/vulnerability/CVE-2023-47635

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47635/
Summaries are generated and may contain mistakes; the official description above is the record.
