# CVE-2023-47636: Full Path Disclosure via re-export document in pimcore/admin-ui-classic-bundle

> An attacker can obtain the full server file path via an unhandled error in the export feature, aiding further attacks.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Nov 2023
- **Updated:** 29 Aug 2024
- **Also known as:** GHSA-c8hj-w239-5gvf

## What is CVE-2023-47636?

CVE-2023-47636 is a medium-severity vulnerability in pimcore admin-ui-classic-bundle, published on 15 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Pimcore Admin Classic Bundle provides a Backend UI for Pimcore. Full Path Disclosure (FPD) vulnerabilities enable the attacker to see the path to the webroot/file. e.g.: /home/omg/htdocs/file/. Certain vulnerabilities, such as using the load_file() (within a SQL Injection) query to view the page source, require the attacker to have the full path to the file they wish to view. In the case of pimcore, the fopen() function here doesn't have an error handle when the file doesn't exist on the server so the server response raises the full path "fopen(/var/www/html/var/tmp/export-{ uniqe id}.csv)". This issue has been patched in commit `10d178ef771` which has been included in release version 1.2.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2023-47636?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.2.1 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.2.1 |

Products: Pimcore Admin Classic Bundle.

## How do I fix CVE-2023-47636?

Upgrade pimcore/admin-ui-classic-bundle to 1.2.1 or later.

## Is CVE-2023-47636 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47636 exists.

## Other vulnerabilities in pimcore admin-ui-classic-bundle

- [CVE-2024-23646](https://insights.sbomify.com/CVE-2024-23646/): Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip (high 8.8)
- [CVE-2024-23648](https://insights.sbomify.com/CVE-2024-23648/): Pimcore Admin Classic Bundle host header injection in the password reset (high 8.8)
- [CVE-2023-49075](https://insights.sbomify.com/CVE-2023-49075/): Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls (high 8.5)
- [CVE-2024-25625](https://insights.sbomify.com/CVE-2024-25625/): Pimcore Host Header Injection in user invitation link (high 8.1)
- [CVE-2025-24980](https://insights.sbomify.com/CVE-2025-24980/): Pimcore Admin Classic Bundle allows user enumeration (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47636 and fix it if it is affected.

What it is: CVE-2023-47636 is a medium-severity vulnerability in pimcore admin-ui-classic-bundle, published on 15 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47636 exists.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.2.1
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47636/ (Markdown: https://insights.sbomify.com/CVE-2023-47636/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47636
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47636
- OSV: https://osv.dev/vulnerability/CVE-2023-47636

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47636/
Summaries are generated and may contain mistakes; the official description above is the record.
