# CVE-2023-47639: API Platform Core can leak exceptions message that may contain sensitive information

> Attackers can view sensitive exception messages in JSON error responses, potentially exposing internal system details.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2025
- **Updated:** 3 Apr 2025
- **Also known as:** GHSA-rfw5-cqjj-7v9r

## What is CVE-2023-47639?

CVE-2023-47639 is a medium-severity vulnerability in api-platform core, published on 3 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

API Platform Core is a system to create hypermedia-driven REST and GraphQL APIs. From 3.2.0 until 3.2.4, exception messages, that are not HTTP exceptions, are visible in the JSON error response. This vulnerability is fixed in 3.2.5.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2023-47639?

2 open source packages ship an affected version, including api-platform/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `api-platform/core` | Packagist | From 3.2.0 | 3.2.5 |
| `api-platform/core` | Packagist | From 3.2.0 | 3.2.5 |

## How do I fix CVE-2023-47639?

Upgrade api-platform/core to 3.2.5 or later.

## Is CVE-2023-47639 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47639 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47639 and fix it if it is affected.

What it is: CVE-2023-47639 is a medium-severity vulnerability in api-platform core, published on 3 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-47639 exists.

Affected packages and fixed versions:
- api-platform/core (Packagist): affected from 3.2.0; fixed in 3.2.5
- api-platform/core (Packagist): affected from 3.2.0; fixed in 3.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47639/ (Markdown: https://insights.sbomify.com/CVE-2023-47639/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47639
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47639
- OSV: https://osv.dev/vulnerability/CVE-2023-47639

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47639/
Summaries are generated and may contain mistakes; the official description above is the record.
