CVE-2023-4771 Cross-Site Scripting vulnerability in CKSource CKEditor

Medium 6.1 Published Updated

An attacker can inject malicious JavaScript via a sample file to steal authorized user information in CKEditor.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-4771?

CVE-2023-4771 is a medium-severity cross-site scripting vulnerability in CKSource CKEditor, published on 16 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A Cross-Site scripting vulnerability has been found in CKSource CKEditor affecting versions 4.15.1 and earlier. An attacker could send malicious javascript code through the /ckeditor/samples/old/ajax.html file and retrieve an authorized user's information.

Weakness: CWE-79

Which versions are affected by CVE-2023-4771?

2 open source packages ship an affected version, including ckeditor4. It affects 1 product.

PackageAffectedFixed in
ckeditor4 npmAll versions4.24.0-lts
ckeditor4 npmAll versions4.24.0-lts

Products include Cksource Ckeditor.

How do I fix CVE-2023-4771?

Upgrade ckeditor4 to 4.24.0-lts or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-4771 being exploited?

There is no known exploitation of CVE-2023-4771 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2023-4771, GHSA-wh5w-82f3-wrxh, UBUNTU-CVE-2023-4771.

Is CVE-2023-4771 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free