# CVE-2023-47865: Username and Icon override can be used by members when Hardened Mode is enabled

> Members can bypass Hardened Mode restrictions to override usernames and icons in posts, requiring a patch to enforce security settings.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-jj46-9cgh-qmfx

## What is CVE-2023-47865?

CVE-2023-47865 is a medium-severity missing authorization vulnerability in Mattermost Mattermost, published on 27 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost fails to check if hardened mode is enabled when overriding the username and/or the icon when posting a post. If settings allowed integrations to override the username and profile picture when posting, a member could also override the username and icon when making a post even if the Hardened Mode setting was enabled

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-47865?

4 open source packages ship an affected version, including github.com/mattermost/mattermost-server/v6 and github.com/mattermost/mattermost/server/v8. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | 7.8.13 |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | 7.8.13 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.1.4 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.1.4 |

Products: Mattermost Mattermost.

## How do I fix CVE-2023-47865?

Upgrade github.com/mattermost/mattermost-server/v6 to 7.8.13 or later.

## Is CVE-2023-47865 being exploited?

There is no known exploitation of CVE-2023-47865 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost

- [CVE-2019-20851](https://insights.sbomify.com/CVE-2019-20851/): Path traversal in n/a (critical 9.1)
- [CVE-2024-39274](https://insights.sbomify.com/CVE-2024-39274/): Malicious remote can add users to arbitrary teams and channels (high 8.7)
- [CVE-2024-39777](https://insights.sbomify.com/CVE-2024-39777/): Malicious remote can invite itself to an arbitrary local channel (high 8.7)
- [CVE-2024-39830](https://insights.sbomify.com/CVE-2024-39830/): Timing attack during remote cluster token comparison when shared channels are enabled (high 8.1)
- [CVE-2023-3615](https://insights.sbomify.com/CVE-2023-3615/): Lack of server certificate validation in websockets connection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-47865 and fix it if it is affected.

What it is: CVE-2023-47865 is a medium-severity missing authorization vulnerability in Mattermost Mattermost, published on 27 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-47865 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; fixed in 7.8.13
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; fixed in 7.8.13
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.1.4
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-47865/ (Markdown: https://insights.sbomify.com/CVE-2023-47865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-47865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-47865
- OSV: https://osv.dev/vulnerability/CVE-2023-47865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-47865/
Summaries are generated and may contain mistakes; the official description above is the record.
