# CVE-2023-48052: HTTPie allows attackers to eavesdrop on communications between the host and server via a man-in-the-middle attack

> Attackers can intercept sensitive data via man-in-the-middle attacks due to missing SSL certificate validation in HTTPie.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Nov 2023
- **Updated:** 14 Aug 2024
- **Also known as:** DEBIAN-CVE-2023-48052, GHSA-8r96-8889-qg2x, OESA-2025-2356, OESA-2025-2357, OESA-2025-2358, PYSEC-2023-242, UBUNTU-CVE-2023-48052

## What is CVE-2023-48052?

CVE-2023-48052 is a high-severity vulnerability in n/a, published on 16 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Missing SSL certificate validation in HTTPie v3.2.2 allows attackers to eavesdrop on communications between the host and server via a man-in-the-middle attack.

Weakness: CWE-295 (Improper Certificate Validation), CWE-599 (Missing Validation of OpenSSL Certificate)

## Which versions are affected by CVE-2023-48052?

3 open source packages ship an affected version, including httpie. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httpie` | PyPI | All versions | None |
| `httpie` | PyPI | All versions | 3.2.3 |
| `httpie` | PyPI | All versions | 3.2.3 |

Products: Httpie Httpie.

## How do I fix CVE-2023-48052?

Upgrade httpie to 3.2.3 or later.

## Is CVE-2023-48052 being exploited?

There is no known exploitation of CVE-2023-48052 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-10751](https://insights.sbomify.com/CVE-2019-10751/): Open Redirect in httpie (high 8.8)
- [CVE-2022-0430](https://insights.sbomify.com/CVE-2022-0430/): Exposure of Sensitive Information to an Unauthorized Actor in httpie/httpie (low 2.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48052 and fix it if it is affected.

What it is: CVE-2023-48052 is a high-severity vulnerability in n/a, published on 16 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-48052 in the wild and no public exploit code.

Affected packages and fixed versions:
- httpie (PyPI): affected all versions; no fix listed
- httpie (PyPI): affected all versions; fixed in 3.2.3
- httpie (PyPI): affected all versions; fixed in 3.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48052/ (Markdown: https://insights.sbomify.com/CVE-2023-48052/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48052
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48052
- OSV: https://osv.dev/vulnerability/CVE-2023-48052

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48052/
Summaries are generated and may contain mistakes; the official description above is the record.
