CVE-2023-4812 Incorrect Authorization in GitLab

High 7.6 Published Updated

Attackers can bypass CODEOWNERS approval requirements in GitLab EE by adding changes to previously approved merge requests.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-4812?

CVE-2023-4812 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 12 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 15.3 before 16.5.6, all versions starting from 16.6 before 16.6.4, all versions starting from 16.7 before 16.7.2. The required CODEOWNERS approval could be bypassed by adding changes to a previously approved merge request.

Weakness: CWE-863

Which versions are affected by CVE-2023-4812?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.3.016.5.6, 16.6.4, 16.7.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-4812?

Upgrade gitlab to a fixed version for your release line: 16.5.6, 16.6.4 or 16.7.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-4812 being exploited?

There is no known exploitation of CVE-2023-4812 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-4812, GHSA-5q5j-r39w-wc64, UBUNTU-CVE-2023-4812.

Is CVE-2023-4812 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free