{"answers":{"affected":"2 open source packages ship an affected version, including strapi-plugin-protected-populate. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-48218 in the wild and no public exploit code.","fix":"Upgrade strapi-plugin-protected-populate to 1.3.4 or later.","what":"CVE-2023-48218 is a medium-severity missing authorization vulnerability in strapi-community strapi-plugin-protected-populate, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-48218 and fix it if it is affected.\n\nWhat it is: CVE-2023-48218 is a medium-severity missing authorization vulnerability in strapi-community strapi-plugin-protected-populate, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-48218 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- strapi-plugin-protected-populate (npm): affected all versions; fixed in 1.3.4\n- strapi-plugin-protected-populate (npm): affected all versions; fixed in 1.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-48218/ (Markdown: https://insights.sbomify.com/CVE-2023-48218/index.md)","id":"CVE-2023-48218","markdown":"https://insights.sbomify.com/CVE-2023-48218/index.md","name":"CVE-2023-48218","record":{"aliases":["GHSA-6h67-934r-82g7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Strapi CMS plugin","requires_auth":"none","summary":"Attackers can bypass field-level security in the Strapi Protected Populate plugin to read restricted data fields.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"protected_populate","vendor":"strapi"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"The Strapi Protected Populate Plugin protects `get` endpoints from revealing too much information. Prior to version 1.3.4, users were able to bypass the field level security. Users who tried to populate something that they didn't have access to could populate those fields anyway. This issue has been patched in version 1.3.4. There are no known workarounds.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Bypass of field access control in strapi-plugin-protected-populate","id":"CVE-2023-48218","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Special characters in unescaped text nodes can trigger mXSS in TinyMCE","id":"CVE-2023-48219"},"packages":[{"ecosystem":"npm","fixed":["1.3.4"],"introduced":["0"],"last_affected":[],"package":"strapi-plugin-protected-populate","purl":null,"source":"GHSA-6h67-934r-82g7"},{"ecosystem":"npm","fixed":["1.3.4"],"introduced":["0"],"last_affected":[],"package":"strapi-plugin-protected-populate","purl":"pkg:npm/strapi-plugin-protected-populate","source":"GHSA-6h67-934r-82g7"}],"prev":{"headline":"Remote code execution via form uploads in statamic/cms","id":"CVE-2023-48217"},"products":["strapi-plugin-protected-populate"],"published":"2023-11-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["strapi-community"]},"summary":"Attackers can bypass field-level security in the Strapi Protected Populate plugin to read restricted data fields.","url":"https://insights.sbomify.com/CVE-2023-48218/"}