# CVE-2023-48218: Bypass of field access control in strapi-plugin-protected-populate

> Attackers can bypass field-level security in the Strapi Protected Populate plugin to read restricted data fields.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-6h67-934r-82g7

## What is CVE-2023-48218?

CVE-2023-48218 is a medium-severity missing authorization vulnerability in strapi-community strapi-plugin-protected-populate, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Strapi Protected Populate Plugin protects `get` endpoints from revealing too much information. Prior to version 1.3.4, users were able to bypass the field level security. Users who tried to populate something that they didn't have access to could populate those fields anyway. This issue has been patched in version 1.3.4. There are no known workarounds.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-48218?

2 open source packages ship an affected version, including strapi-plugin-protected-populate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `strapi-plugin-protected-populate` | npm | All versions | 1.3.4 |
| `strapi-plugin-protected-populate` | npm | All versions | 1.3.4 |

Products: Strapi Protected Populate.

## How do I fix CVE-2023-48218?

Upgrade strapi-plugin-protected-populate to 1.3.4 or later.

## Is CVE-2023-48218 being exploited?

There is no known exploitation of CVE-2023-48218 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48218 and fix it if it is affected.

What it is: CVE-2023-48218 is a medium-severity missing authorization vulnerability in strapi-community strapi-plugin-protected-populate, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-48218 in the wild and no public exploit code.

Affected packages and fixed versions:
- strapi-plugin-protected-populate (npm): affected all versions; fixed in 1.3.4
- strapi-plugin-protected-populate (npm): affected all versions; fixed in 1.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48218/ (Markdown: https://insights.sbomify.com/CVE-2023-48218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48218
- OSV: https://osv.dev/vulnerability/CVE-2023-48218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48218/
Summaries are generated and may contain mistakes; the official description above is the record.
