# CVE-2023-48219: Special characters in unescaped text nodes can trigger mXSS in TinyMCE

> Attackers can execute arbitrary scripts via mutation XSS in TinyMCE's undo/redo functionality by exploiting unescaped text nodes.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Nov 2023
- **Updated:** 29 Aug 2024
- **Also known as:** GHSA-v626-r774-j7f8, UBUNTU-CVE-2023-48219

## What is CVE-2023-48219?

CVE-2023-48219 is a medium-severity cross-site scripting vulnerability in tinymce, published on 15 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

TinyMCE is an open source rich text editor. A mutation cross-site scripting (mXSS) vulnerability was discovered in TinyMCE’s core undo/redo functionality and other APIs and plugins. Text nodes within specific parents are not escaped upon serialization according to the HTML standard. If such text nodes contain a special character reserved as an internal marker, they can be combined with other HTML patterns to form malicious snippets. These snippets pass the initial sanitisation layer when the content is parsed into the editor body, but can trigger XSS when the special internal marker is removed from the content and re-parsed. his vulnerability has been patched in TinyMCE versions 6.7.3 and 5.10.9. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-48219?

12 open source packages ship an affected version, including TinyMCE, tinymce/tinymce and tinymce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `TinyMCE` | NuGet | All versions | 5.10.9 |
| `TinyMCE` | NuGet | All versions | 5.10.9 |
| `TinyMCE` | NuGet | From 6.0.0 | 6.7.3 |
| `TinyMCE` | NuGet | From 6.0.0 | 6.7.3 |
| `tinymce/tinymce` | Packagist | All versions | 5.10.9 |
| `tinymce/tinymce` | Packagist | All versions | 5.10.9 |
| `tinymce/tinymce` | Packagist | From 6.0.0 | 6.7.3 |
| `tinymce/tinymce` | Packagist | From 6.0.0 | 6.7.3 |
| `tinymce` | npm | All versions | 5.10.9 |
| `tinymce` | npm | All versions | 5.10.9 |
| `tinymce` | npm | From 6.0.0 | 6.7.3 |
| `tinymce` | npm | From 6.0.0 | 6.7.3 |

Products: Tiny Tinymce.

## How do I fix CVE-2023-48219?

Upgrade TinyMCE to a fixed version for your release line: 5.10.9 or 6.7.3.

## Is CVE-2023-48219 being exploited?

There is no known exploitation of CVE-2023-48219 in the wild and no public exploit code.

## Other vulnerabilities in tinymce

- [CVE-2026-47759](https://insights.sbomify.com/CVE-2026-47759/): TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes (high 8.7)
- [CVE-2026-47760](https://insights.sbomify.com/CVE-2026-47760/): TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs (high 8.7)
- [CVE-2026-47761](https://insights.sbomify.com/CVE-2026-47761/): TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection (high 8.7)
- [CVE-2026-47762](https://insights.sbomify.com/CVE-2026-47762/): TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments (high 8.7)
- [CVE-2024-21908](https://insights.sbomify.com/CVE-2024-21908/): Cross-site scripting vulnerability in TinyMCE (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48219 and fix it if it is affected.

What it is: CVE-2023-48219 is a medium-severity cross-site scripting vulnerability in tinymce, published on 15 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-48219 in the wild and no public exploit code.

Affected packages and fixed versions:
- TinyMCE (NuGet): affected all versions; fixed in 5.10.9
- TinyMCE (NuGet): affected all versions; fixed in 5.10.9
- TinyMCE (NuGet): affected from 6.0.0; fixed in 6.7.3
- TinyMCE (NuGet): affected from 6.0.0; fixed in 6.7.3
- tinymce/tinymce (Packagist): affected all versions; fixed in 5.10.9
- tinymce/tinymce (Packagist): affected all versions; fixed in 5.10.9
- tinymce/tinymce (Packagist): affected from 6.0.0; fixed in 6.7.3
- tinymce/tinymce (Packagist): affected from 6.0.0; fixed in 6.7.3
- tinymce (npm): affected all versions; fixed in 5.10.9
- tinymce (npm): affected all versions; fixed in 5.10.9
- tinymce (npm): affected from 6.0.0; fixed in 6.7.3
- tinymce (npm): affected from 6.0.0; fixed in 6.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48219/ (Markdown: https://insights.sbomify.com/CVE-2023-48219/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48219
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48219
- OSV: https://osv.dev/vulnerability/CVE-2023-48219

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48219/
Summaries are generated and may contain mistakes; the official description above is the record.
