# CVE-2023-4822: Grafana privilege escalation vulnerability

> An Organization Admin can escalate privileges or modify permissions globally across all organizations, requiring multi-org setup.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2023
- **Updated:** 30 Jan 2026
- **Also known as:** BIT-grafana-2023-4822, GHSA-fw9c-75hh-89p6, UBUNTU-CVE-2023-4822

## What is CVE-2023-4822?

CVE-2023-4822 is a medium-severity vulnerability in Grafana Grafana, published on 16 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Grafana is an open-source platform for monitoring and observability. The vulnerability impacts Grafana instances with several organizations, and allows a user with Organization Admin permissions in one organization to change the permissions associated with Organization Viewer, Organization Editor and Organization Admin roles in all organizations.

It also allows an Organization Admin to assign or revoke any permissions that they have to any user globally.

This means that any Organization Admin can elevate their own permissions in any organization that they are already a member of, or elevate or restrict the permissions of any other user.

The vulnerability does not allow a user to become a member of an organization that they are not already a member of, or to add any other users to an organization that the current user is not a member of.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-4822?

3 open source packages ship an affected version, including github.com/grafana/grafana and grafana. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grafana/grafana` | Go | All versions to 10.1.5 | None |
| `github.com/grafana/grafana` | Go | All versions to 10.1.5 | None |
| `grafana` | Bitnami | From 8.0.0 to 10.1.4 | 9.4.16, 9.5.11, 10.0.7, 10.1.3 |

Products: Grafana Grafana.

## How do I fix CVE-2023-4822?

Apply the vendor's patch.

## Is CVE-2023-4822 being exploited?

There is no known exploitation of CVE-2023-4822 in the wild and no public exploit code.

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-4822 and fix it if it is affected.

What it is: CVE-2023-4822 is a medium-severity vulnerability in Grafana Grafana, published on 16 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-4822 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grafana/grafana (Go): affected all versions up to 10.1.5; no fix listed
- github.com/grafana/grafana (Go): affected all versions up to 10.1.5; no fix listed
- grafana (Bitnami): affected from 8.0.0 up to 10.1.4; fixed in 9.4.16, 9.5.11, 10.0.7, 10.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-4822/ (Markdown: https://insights.sbomify.com/CVE-2023-4822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-4822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-4822
- OSV: https://osv.dev/vulnerability/CVE-2023-4822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-4822/
Summaries are generated and may contain mistakes; the official description above is the record.
