# CVE-2023-48221: wire-avs remote format string vulnerability

> A remote format string vulnerability in the Wire AVS library allows attackers to cause denial of service or execute arbitrary code.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-m4xg-fcr3-w3pq

## What is CVE-2023-48221?

CVE-2023-48221 is a high-severity vulnerability in wireapp wire-avs, published on 20 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

wire-avs provides Audio, Visual, and Signaling (AVS) functionality sure the secure messaging software Wire. Prior to versions 9.2.22 and 9.3.5, a remote format string vulnerability could potentially allow an attacker to cause a denial of service or possibly execute arbitrary code. The issue has been fixed in wire-avs 9.2.22 & 9.3.5 and is already included on all Wire products. No known workarounds are available.

Weakness: CWE-134 (Use of Externally-Controlled Format String)

## Which versions are affected by CVE-2023-48221?

It affects 1 product.


Products: Wire Audio\, Video\, and Signaling.

## How do I fix CVE-2023-48221?

No fix has been published for CVE-2023-48221 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-48221 being exploited?

There is no known exploitation of CVE-2023-48221 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48221 and fix it if it is affected.

What it is: CVE-2023-48221 is a high-severity vulnerability in wireapp wire-avs, published on 20 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-48221 in the wild and no public exploit code.

Affected product: wireapp wire-avs. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48221/ (Markdown: https://insights.sbomify.com/CVE-2023-48221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48221
- OSV: https://osv.dev/vulnerability/CVE-2023-48221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48221/
Summaries are generated and may contain mistakes; the official description above is the record.
