CVE-2023-48228 OAuth2: PKCE can be fully circumvented

High 7.5 Published Updated

Attackers can bypass PKCE protection in OAuth2 flows by omitting the code verifier, potentially leading to unauthorized access.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-48228?

CVE-2023-48228 is a high-severity authentication bypass vulnerability in goauthentik authentik, published on 21 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

authentik is an open-source identity provider. When initialising a oauth2 flow with a `code_challenge` and `code_method` (thus requesting PKCE), the single sign-on provider (authentik) must check if there is a matching and existing `code_verifier` during the token step. Prior to versions 2023.10.4 and 2023.8.5, authentik checks if the contents of `code_verifier` is matching only when it is provided. When it is left out completely, authentik simply accepts the token request with out it; even when the flow was started with a `code_challenge`. authentik 2023.8.5 and 2023.10.4 fix this issue.

Weakness: CWE-287

Which versions are affected by CVE-2023-48228?

1 open source package ship an affected version, including authentik. It affects 1 product.

PackageAffectedFixed in
authentik BitnamiAll versions2023.8.5, 2023.10.4

Products include Goauthentik Authentik.

How do I fix CVE-2023-48228?

Upgrade authentik to a fixed version for your release line: 2023.8.5 or 2023.10.4.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2023-48228 being exploited?

There is no known exploitation of CVE-2023-48228 in the wild and no public exploit code.

Sources

Also known as BIT-authentik-2023-48228, GHSA-fm34-v8xq-f2c3.

Is CVE-2023-48228 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free