# CVE-2023-48228: OAuth2: PKCE can be fully circumvented

> Attackers can bypass PKCE protection in OAuth2 flows by omitting the code verifier, potentially leading to unauthorized access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-authentik-2023-48228, GHSA-fm34-v8xq-f2c3

## What is CVE-2023-48228?

CVE-2023-48228 is a high-severity authentication bypass vulnerability in goauthentik authentik, published on 21 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

authentik is an open-source identity provider. When initialising a oauth2 flow with a `code_challenge` and `code_method` (thus requesting PKCE), the single sign-on provider (authentik) must check if there is a matching and existing `code_verifier` during the token step. Prior to versions 2023.10.4 and 2023.8.5, authentik checks if the contents of `code_verifier` is matching only when it is provided. When it is left out completely, authentik simply accepts the token request with out it; even when the flow was started with a `code_challenge`. authentik 2023.8.5 and 2023.10.4 fix this issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-48228?

1 open source package ship an affected version, including authentik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2023.8.5, 2023.10.4 |

Products: Goauthentik Authentik.

## How do I fix CVE-2023-48228?

Upgrade authentik to a fixed version for your release line: 2023.8.5 or 2023.10.4.

## Is CVE-2023-48228 being exploited?

There is no known exploitation of CVE-2023-48228 in the wild and no public exploit code.

## Other vulnerabilities in goauthentik authentik

- [CVE-2026-49448](https://insights.sbomify.com/CVE-2026-49448/): authentik: SourceStage bypass via empty POST (critical 9.8)
- [CVE-2023-46249](https://insights.sbomify.com/CVE-2023-46249/): authentik potential installation takeover when default admin user is deleted (critical 9.7)
- [CVE-2022-23555](https://insights.sbomify.com/CVE-2022-23555/): authentik vulnerable to Improper Authentication via invitation URL token reuse (critical 9.4)
- [CVE-2026-42849](https://insights.sbomify.com/CVE-2026-42849/): authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover (critical 9.3)
- [CVE-2026-25227](https://insights.sbomify.com/CVE-2026-25227/): authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48228 and fix it if it is affected.

What it is: CVE-2023-48228 is a high-severity authentication bypass vulnerability in goauthentik authentik, published on 21 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-48228 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2023.8.5, 2023.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48228/ (Markdown: https://insights.sbomify.com/CVE-2023-48228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48228
- OSV: https://osv.dev/vulnerability/CVE-2023-48228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48228/
Summaries are generated and may contain mistakes; the official description above is the record.
