# CVE-2023-48241: XWiki exposed whole content of all documents of all wikis to anybody with view right on Solr suggest service

> Attackers with view rights can bypass authorization checks to read all wiki content via the Solr search service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-7fqr-97j7-jgf4

## What is CVE-2023-48241?

CVE-2023-48241 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in version 6.3-milestone-2 and prior to versions 14.10.15, 15.5.1, and 15.6RC1, the Solr-based search suggestion provider that also duplicates as generic JavaScript API for search results in XWiki exposes the content of all documents of all wikis to anybody who has access to it, by default it is public. This exposes all information stored in the wiki (but not some protected information like password hashes). While there is a right check normally, the right check can be circumvented by explicitly requesting fields from Solr that don't include the data for the right check. This has been fixed in XWiki 15.6RC1, 15.5.1 and 14.10.15 by not listing documents whose rights cannot be checked. No known workarounds are available.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2023-48241?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-search-solr-query. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-search-solr-query` | Maven | From 15.0-rc-1 | 15.5.1 |
| `org.xwiki.platform:xwiki-platform-search-solr-query` | Maven | From 15.0-rc-1 | 15.5.1 |
| `org.xwiki.platform:xwiki-platform-search-solr-query` | Maven | From 6.3-milestone-2 | 14.10.15 |
| `org.xwiki.platform:xwiki-platform-search-solr-query` | Maven | From 6.3-milestone-2 | 14.10.15 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-48241?

Upgrade org.xwiki.platform:xwiki-platform-search-solr-query to a fixed version for your release line: 15.5.1 or 14.10.15.

## Is CVE-2023-48241 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-48241 exists.

Public exploit code:

- XWiki < 4.10.15 - Information Disclosure (nuclei): http/cves/2023/CVE-2023-48241.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48241 and fix it if it is affected.

What it is: CVE-2023-48241 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-48241 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-search-solr-query (Maven): affected from 15.0-rc-1; fixed in 15.5.1
- org.xwiki.platform:xwiki-platform-search-solr-query (Maven): affected from 15.0-rc-1; fixed in 15.5.1
- org.xwiki.platform:xwiki-platform-search-solr-query (Maven): affected from 6.3-milestone-2; fixed in 14.10.15
- org.xwiki.platform:xwiki-platform-search-solr-query (Maven): affected from 6.3-milestone-2; fixed in 14.10.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48241/ (Markdown: https://insights.sbomify.com/CVE-2023-48241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48241
- OSV: https://osv.dev/vulnerability/CVE-2023-48241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48241/
Summaries are generated and may contain mistakes; the official description above is the record.
