CVE-2023-48291 Apache Airflow: Improper access control to DAG resources

Medium 4.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2023-48291?

CVE-2023-48291 is a medium-severity vulnerability in Apache Airflow, published on 21 Dec 2023.

Official description

Apache Airflow, in versions prior to 2.8.0, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't.

This is a missing fix for CVE-2023-42792 in Apache Airflow 2.7.2 

Users of Apache Airflow are strongly advised to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability.

Weakness: CWE-668

Which versions are affected by CVE-2023-48291?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIAll versions2.8.0
apache-airflow PyPIAll versions2.8.0
apache-airflow PyPIAll versions2.8.0
airflow BitnamiAll versions2.8.0

Products include Apache Airflow.

How do I fix CVE-2023-48291?

Upgrade apache-airflow to 2.8.0 or later.

Is CVE-2023-48291 being exploited?

There is no known exploitation of CVE-2023-48291 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2023-48291, ECHO-bed1-5e00-330d, GHSA-8f57-wcmg-4jmh, PYSEC-2023-265.

Is CVE-2023-48291 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free