# CVE-2023-48291: Apache Airflow: Improper access control to DAG resources


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Dec 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-airflow-2023-48291, ECHO-bed1-5e00-330d, GHSA-8f57-wcmg-4jmh, PYSEC-2023-265

## What is CVE-2023-48291?

CVE-2023-48291 is a medium-severity vulnerability in Apache Airflow, published on 21 Dec 2023. 

### Official description

Apache Airflow, in versions prior to 2.8.0, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't.

This is a missing fix for CVE-2023-42792 in Apache Airflow 2.7.2 

Users of Apache Airflow are strongly advised to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2023-48291?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.8.0 |
| `apache-airflow` | PyPI | All versions | 2.8.0 |
| `apache-airflow` | PyPI | All versions | 2.8.0 |
| `airflow` | Bitnami | All versions | 2.8.0 |

Products: Apache Airflow.

## How do I fix CVE-2023-48291?

Upgrade apache-airflow to 2.8.0 or later.

## Is CVE-2023-48291 being exploited?

There is no known exploitation of CVE-2023-48291 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48291 and fix it if it is affected.

What it is: CVE-2023-48291 is a medium-severity vulnerability in Apache Airflow, published on 21 Dec 2023. 
Exploitation: There is no known exploitation of CVE-2023-48291 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.8.0
- apache-airflow (PyPI): affected all versions; fixed in 2.8.0
- apache-airflow (PyPI): affected all versions; fixed in 2.8.0
- airflow (Bitnami): affected all versions; fixed in 2.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48291/ (Markdown: https://insights.sbomify.com/CVE-2023-48291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48291
- OSV: https://osv.dev/vulnerability/CVE-2023-48291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48291/
Summaries are generated and may contain mistakes; the official description above is the record.
