# CVE-2023-48292: XWiki Admin Tools Application Run Shell Command allows CSRF RCE attacks

> Attackers can trick admins into executing arbitrary shell commands via CSRF, leading to remote code execution and full system compromise.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-8jpr-ff92-hpf9

## What is CVE-2023-48292?

CVE-2023-48292 is a critical vulnerability in xwiki-contrib application-admintools, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The XWiki Admin Tools Application provides tools to help the administration of XWiki. Starting in version 4.4 and prior to version 4.5.1, a cross site request forgery vulnerability in the admin tool for executing shell commands on the server allows an attacker to execute arbitrary shell commands by tricking an admin into loading the URL with the shell command. A very simple possibility for an attack are comments. When the attacker can leave a comment on any page in the wiki it is sufficient to include an image with an URL like  `/xwiki/bin/view/Admin/RunShellCommand?command=touch%20/tmp/attacked` in the comment. When an admin views the comment, the file `/tmp/attacked` will be created on the server. The output of the command is also vulnerable to XWiki syntax injection which offers a simple way to execute Groovy in the context of the XWiki installation and thus an even easier way to compromise the integrity and confidentiality of the whole XWiki installation. This has been patched by adding a form token check in version 4.5.1 of the admin tools. Some workarounds are available. The patch can be applied manually to the affected wiki pages. Alternatively, the document `Admin.RunShellCommand` can also be deleted if the possibility to run shell commands isn't needed.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-48292?

2 open source packages ship an affected version, including org.xwiki.contrib:xwiki-application-admintools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.contrib:xwiki-application-admintools` | Maven | From 4.4 | 4.5.1 |
| `org.xwiki.contrib:xwiki-application-admintools` | Maven | From 4.4 | 4.5.1 |

Products: Xwiki Admin Tools.

## How do I fix CVE-2023-48292?

Upgrade org.xwiki.contrib:xwiki-application-admintools to 4.5.1 or later.

## Is CVE-2023-48292 being exploited?

There is no known exploitation of CVE-2023-48292 in the wild and no public exploit code.

Public exploit code:

- XWiki Standard 14.10 - Remote Code Execution (RCE) (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48292 and fix it if it is affected.

What it is: CVE-2023-48292 is a critical vulnerability in xwiki-contrib application-admintools, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-48292 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.contrib:xwiki-application-admintools (Maven): affected from 4.4; fixed in 4.5.1
- org.xwiki.contrib:xwiki-application-admintools (Maven): affected from 4.4; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48292/ (Markdown: https://insights.sbomify.com/CVE-2023-48292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48292
- OSV: https://osv.dev/vulnerability/CVE-2023-48292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48292/
Summaries are generated and may contain mistakes; the official description above is the record.
