# CVE-2023-48293: XWiki Admin Tools Application CSRF with QueryOnXWiki allows arbitrary database queries

> Cross-site request forgery in XWiki Admin Tools allows attackers to execute arbitrary database queries, potentially deleting data or creating privileged accounts.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Nov 2023
- **Updated:** 11 Oct 2024
- **Also known as:** GHSA-4f4c-rhjv-4wgv

## What is CVE-2023-48293?

CVE-2023-48293 is a high-severity vulnerability in Xwiki Xwiki, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The XWiki Admin Tools Application provides tools to help the administration of XWiki. Prior to version 4.5.1, a cross-site request forgery vulnerability in the query on XWiki tool allows executing arbitrary database queries on the database of the XWiki installation. Among other things, this allows modifying and deleting all data of the wiki. This could be both used to damage the wiki and to create an account with elevated privileges for the attacker, thus impacting the confidentiality, integrity and availability of the whole XWiki instance. A possible attack vector are comments on the wiki, by embedding an image with wiki syntax like `[[image:path:/xwiki/bin/view/Admin/QueryOnXWiki?query=DELETE%20FROM%20xwikidoc]]`, all documents would be deleted from the database when an admin user views this comment. This has been patched in Admin Tools Application 4.5.1 by adding form token checks. Some workarounds are available. The patch can also be applied manually to the affected pages. Alternatively, if the query tool is not needed, by deleting the document `Admin.SQLToolsGroovy`, all database query tools can be deactivated.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-48293?

2 open source packages ship an affected version, including org.xwiki.contrib:xwiki-application-admintools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.contrib:xwiki-application-admintools` | Maven | All versions | 4.5.1 |
| `org.xwiki.contrib:xwiki-application-admintools` | Maven | All versions | 4.5.1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-48293?

Upgrade org.xwiki.contrib:xwiki-application-admintools to 4.5.1 or later.

## Is CVE-2023-48293 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-48293 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48293 and fix it if it is affected.

What it is: CVE-2023-48293 is a high-severity vulnerability in Xwiki Xwiki, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-48293 exists.

Affected packages and fixed versions:
- org.xwiki.contrib:xwiki-application-admintools (Maven): affected all versions; fixed in 4.5.1
- org.xwiki.contrib:xwiki-application-admintools (Maven): affected all versions; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48293/ (Markdown: https://insights.sbomify.com/CVE-2023-48293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48293
- OSV: https://osv.dev/vulnerability/CVE-2023-48293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48293/
Summaries are generated and may contain mistakes; the official description above is the record.
