# CVE-2023-48295: Cross-site Scripting at Device groups Deletion feature in LibreNMS

> An attacker can execute arbitrary scripts in the context of other users via the device group deletion feature in LibreNMS.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Nov 2023
- **Updated:** 10 Aug 2024
- **Also known as:** GHSA-8phr-637g-pxrg

## What is CVE-2023-48295?

CVE-2023-48295 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 17 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring which includes support for a wide range of network hardware and operating systems. Affected versions are subject to a cross site scripting (XSS) vulnerability in the device group popups. This issue has been addressed in commit `faf66035ea` which has been included in release version 23.11.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-48295?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 23.11.0 |
| `librenms/librenms` | Packagist | All versions | 23.11.0 |

Products: Librenms Librenms.

## How do I fix CVE-2023-48295?

Upgrade librenms/librenms to 23.11.0 or later.

## Is CVE-2023-48295 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-48295 exists.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48295 and fix it if it is affected.

What it is: CVE-2023-48295 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 17 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-48295 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 23.11.0
- librenms/librenms (Packagist): affected all versions; fixed in 23.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48295/ (Markdown: https://insights.sbomify.com/CVE-2023-48295/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48295
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48295
- OSV: https://osv.dev/vulnerability/CVE-2023-48295

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48295/
Summaries are generated and may contain mistakes; the official description above is the record.
