CVE-2023-48297 Discourse vulnerable to unlimited mentioned users in message serializer

High 8.6 Published Updated

Attackers can cause denial of service by triggering excessive user expansion in chat mentions, impacting Discourse forum availability.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-48297?

CVE-2023-48297 is a high-severity denial of service vulnerability in Discourse Discourse, published on 12 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is a platform for community discussion. The message serializer uses the full list of expanded chat mentions (@all and @here) which can lead to a very long array of users. This issue was patched in versions 3.1.4 and beta 3.2.0.beta5.

Weakness: CWE-400

Which versions are affected by CVE-2023-48297?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.1.4

Products include Discourse Discourse.

How do I fix CVE-2023-48297?

Upgrade discourse to 3.1.4 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-48297 being exploited?

There is no known exploitation of CVE-2023-48297 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-48297, GHSA-hf2v-r5xm-8p37.

Is CVE-2023-48297 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free