{"answers":{"affected":"3 open source packages ship an affected version, including dockerspawner. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-48311 in the wild and no public exploit code.","fix":"Upgrade dockerspawner to 13.0.0 or later.","what":"CVE-2023-48311 is a high-severity vulnerability in jupyterhub dockerspawner, published on 8 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-48311 and fix it if it is affected.\n\nWhat it is: CVE-2023-48311 is a high-severity vulnerability in jupyterhub dockerspawner, published on 8 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-48311 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dockerspawner (PyPI): affected from 0.11.0; fixed in 13.0.0\n- dockerspawner (PyPI): affected from 0.11.0; fixed in 13.0.0\n- dockerspawner (PyPI): affected from 0.11.0; fixed in 13.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-48311/ (Markdown: https://insights.sbomify.com/CVE-2023-48311/index.md)","id":"CVE-2023-48311","markdown":"https://insights.sbomify.com/CVE-2023-48311/index.md","name":"CVE-2023-48311","record":{"aliases":["GHSA-hfgr-h3vc-p6c2","PYSEC-2026-1312"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"JupyterHub Docker spawner","requires_auth":"low_privilege","summary":"Default configuration allows users to launch arbitrary Docker images, potentially leading to code execution or privilege escalation in JupyterHub deployments.","user_interaction":"required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dockerspawner","vendor":"jupyter"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"dockerspawner is a tool to spawn JupyterHub single user servers in Docker containers. Users of JupyterHub deployments running DockerSpawner starting with 0.11.0 without specifying `DockerSpawner.allowed_images` configuration allow users to launch _any_ pullable docker image, instead of restricting to only the single configured image, as intended. This issue has been addressed in commit `3ba4b665b` which has been included in dockerspawner release version 13. Users are advised to upgrade. Users unable to upgrade should explicitly set `DockerSpawner.allowed_images` to a non-empty list containing only the default image will result in the intended default behavior.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Any image allowed by default","id":"CVE-2023-48311","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"misconfiguration","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Authentication bypass using an empty token in capsule-proxy","id":"CVE-2023-48312"},"packages":[{"ecosystem":"PyPI","fixed":["13.0.0"],"introduced":["0.11.0"],"last_affected":[],"package":"dockerspawner","purl":null,"source":"GHSA-hfgr-h3vc-p6c2"},{"ecosystem":"PyPI","fixed":["13.0.0"],"introduced":["0.11.0"],"last_affected":[],"package":"dockerspawner","purl":"pkg:pypi/dockerspawner","source":"GHSA-hfgr-h3vc-p6c2"},{"ecosystem":"PyPI","fixed":["13.0.0"],"introduced":["0.11.0"],"last_affected":[],"package":"dockerspawner","purl":"pkg:pypi/dockerspawner","source":"PYSEC-2026-1312"}],"prev":{"headline":"Ability to DoS the testing infrastructure by overwriting files","id":"CVE-2023-48310"},"products":["dockerspawner"],"published":"2023-12-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["jupyterhub"]},"summary":"Default configuration allows users to launch arbitrary Docker images, potentially leading to code execution or privilege escalation in JupyterHub deployments.","url":"https://insights.sbomify.com/CVE-2023-48311/"}