# CVE-2023-48311: Any image allowed by default

> Default configuration allows users to launch arbitrary Docker images, potentially leading to code execution or privilege escalation in JupyterHub deployments.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-hfgr-h3vc-p6c2, PYSEC-2026-1312

## What is CVE-2023-48311?

CVE-2023-48311 is a high-severity vulnerability in jupyterhub dockerspawner, published on 8 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

dockerspawner is a tool to spawn JupyterHub single user servers in Docker containers. Users of JupyterHub deployments running DockerSpawner starting with 0.11.0 without specifying `DockerSpawner.allowed_images` configuration allow users to launch _any_ pullable docker image, instead of restricting to only the single configured image, as intended. This issue has been addressed in commit `3ba4b665b` which has been included in dockerspawner release version 13. Users are advised to upgrade. Users unable to upgrade should explicitly set `DockerSpawner.allowed_images` to a non-empty list containing only the default image will result in the intended default behavior.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-48311?

3 open source packages ship an affected version, including dockerspawner. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dockerspawner` | PyPI | From 0.11.0 | 13.0.0 |
| `dockerspawner` | PyPI | From 0.11.0 | 13.0.0 |
| `dockerspawner` | PyPI | From 0.11.0 | 13.0.0 |

Products: Jupyter Dockerspawner.

## How do I fix CVE-2023-48311?

Upgrade dockerspawner to 13.0.0 or later.

## Is CVE-2023-48311 being exploited?

There is no known exploitation of CVE-2023-48311 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48311 and fix it if it is affected.

What it is: CVE-2023-48311 is a high-severity vulnerability in jupyterhub dockerspawner, published on 8 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-48311 in the wild and no public exploit code.

Affected packages and fixed versions:
- dockerspawner (PyPI): affected from 0.11.0; fixed in 13.0.0
- dockerspawner (PyPI): affected from 0.11.0; fixed in 13.0.0
- dockerspawner (PyPI): affected from 0.11.0; fixed in 13.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48311/ (Markdown: https://insights.sbomify.com/CVE-2023-48311/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48311
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48311
- OSV: https://osv.dev/vulnerability/CVE-2023-48311

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48311/
Summaries are generated and may contain mistakes; the official description above is the record.
