CVE-2023-48313 Umbraco contains a DOM-XSS
Attackers can inject malicious scripts into Umbraco CMS websites, potentially compromising user sessions or executing code in victim browsers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-48313?
CVE-2023-48313 is a medium-severity cross-site scripting vulnerability in Umbraco Umbraco Cms, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Umbraco is an ASP.NET content management system (CMS). Starting in 10.0.0 and prior to versions 10.8.1 and 12.3.4, Umbraco contains a cross-site scripting (XSS) vulnerability enabling attackers to bring malicious content into a website or application. Versions 10.8.1 and 12.3.4 contain a patch for this issue.
Weakness: CWE-79
Which versions are affected by CVE-2023-48313?
4 open source packages ship an affected version, including Umbraco.CMS. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
Umbraco.CMS NuGet | From 10.0.0 | 10.8.1 |
Umbraco.CMS NuGet | From 10.0.0 | 10.8.1 |
Umbraco.CMS NuGet | From 11.0.0 | 12.3.4 |
Umbraco.CMS NuGet | From 11.0.0 | 12.3.4 |
Products include Umbraco Umbraco Cms.
How do I fix CVE-2023-48313?
Upgrade Umbraco.CMS to a fixed version for your release line: 10.8.1 or 12.3.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-48313 being exploited?
There is no known exploitation of CVE-2023-48313 in the wild and no public exploit code.
Other vulnerabilities in Umbraco Umbraco Cms
- CVE-2025-67288 Umbraco CMS has an arbitrary file upload vulnerability
- CVE-2014-10074 File upload in n/a
- CVE-2012-1301 Server-side request forgery in n/a
- CVE-2012-10054 Umbraco CMS < 4.7.1 codeEditorSave.asmx RCE
- CVE-2025-32017 Umbraco has a Management API Vulnerability to Path Traversal With Authenticated Users
Sources
Also known as GHSA-v98m-398x-269r.