# CVE-2023-48362: Apache Drill: XXE Vulnerability in XML Format Reader

> An attacker can read arbitrary files or execute commands via a malicious XML file in Apache Drill's XML Format Plugin.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-v62g-jwj9-rfvx

## What is CVE-2023-48362?

CVE-2023-48362 is a critical vulnerability in Apache Drill, published on 24 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XXE in the XML Format Plugin in Apache Drill version 1.19.0 and greater allows a user to read any file on a remote file system or execute commands via a malicious XML file.
Users are recommended to upgrade to version 1.21.2, which fixes this issue.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2023-48362?

2 open source packages ship an affected version, including org.apache.drill.exec:drill-java-exec. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.drill.exec:drill-java-exec` | Maven | From 1.19.0 | 1.21.2 |
| `org.apache.drill.exec:drill-java-exec` | Maven | From 1.19.0 | 1.21.2 |

Products: Apache Drill.

## How do I fix CVE-2023-48362?

Upgrade org.apache.drill.exec:drill-java-exec to 1.21.2 or later.

## Is CVE-2023-48362 being exploited?

There is no known exploitation of CVE-2023-48362 in the wild and no public exploit code.

## Other vulnerabilities in Apache Drill

- [CVE-2019-14439](https://insights.sbomify.com/CVE-2019-14439/): Deserialization of untrusted data in FasterXML jackson-databind (high 7.5)
- [CVE-2010-5312](https://insights.sbomify.com/CVE-2010-5312/): Cross-site Scripting in jquery-ui (medium 6.1)
- [CVE-2017-12630](https://insights.sbomify.com/CVE-2017-12630/): Apache Drill vulnerable to Cross-site Scripting (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48362 and fix it if it is affected.

What it is: CVE-2023-48362 is a critical vulnerability in Apache Drill, published on 24 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-48362 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.drill.exec:drill-java-exec (Maven): affected from 1.19.0; fixed in 1.21.2
- org.apache.drill.exec:drill-java-exec (Maven): affected from 1.19.0; fixed in 1.21.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48362/ (Markdown: https://insights.sbomify.com/CVE-2023-48362/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48362
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48362
- OSV: https://osv.dev/vulnerability/CVE-2023-48362

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48362/
Summaries are generated and may contain mistakes; the official description above is the record.
