CVE-2023-48631 Denial of Service of regular expression in package @adobe/css-tools

Medium 5.3 Published Updated

Attackers can cause denial of service by providing malicious CSS input to the @adobe/css-tools library, affecting applications using this npm package.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-48631?

CVE-2023-48631 is a medium-severity denial of service vulnerability in Adobe Not a product, published on 14 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

@adobe/css-tools versions 4.3.1 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS.

Weakness: CWE-1333, CWE-20

Which versions are affected by CVE-2023-48631?

2 open source packages ship an affected version, including @adobe/css-tools. It affects 1 product.

PackageAffectedFixed in
@adobe/css-tools npmAll versions4.3.2
@adobe/css-tools npmAll versions4.3.2

Products include Adobe Css-Tools.

How do I fix CVE-2023-48631?

Upgrade @adobe/css-tools to 4.3.2 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-48631 being exploited?

There is no known exploitation of CVE-2023-48631 in the wild and no public exploit code.

Sources

Also known as GHSA-prr3-c3m5-p7q2.

Is CVE-2023-48631 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free