# CVE-2023-48631: Denial of Service of regular expression in package @adobe/css-tools

> Attackers can cause denial of service by providing malicious CSS input to the @adobe/css-tools library, affecting applications using this npm package.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-prr3-c3m5-p7q2

## What is CVE-2023-48631?

CVE-2023-48631 is a medium-severity denial of service vulnerability in Adobe Not a product, published on 14 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@adobe/css-tools versions 4.3.1 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-48631?

2 open source packages ship an affected version, including @adobe/css-tools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@adobe/css-tools` | npm | All versions | 4.3.2 |
| `@adobe/css-tools` | npm | All versions | 4.3.2 |

Products: Adobe Css-Tools.

## How do I fix CVE-2023-48631?

Upgrade @adobe/css-tools to 4.3.2 or later.

## Is CVE-2023-48631 being exploited?

There is no known exploitation of CVE-2023-48631 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Not a product

- [CVE-2023-26364](https://insights.sbomify.com/CVE-2023-26364/): Denial of Service of regular expression in package @adobe/css-tools (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48631 and fix it if it is affected.

What it is: CVE-2023-48631 is a medium-severity denial of service vulnerability in Adobe Not a product, published on 14 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-48631 in the wild and no public exploit code.

Affected packages and fixed versions:
- @adobe/css-tools (npm): affected all versions; fixed in 4.3.2
- @adobe/css-tools (npm): affected all versions; fixed in 4.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48631/ (Markdown: https://insights.sbomify.com/CVE-2023-48631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48631
- OSV: https://osv.dev/vulnerability/CVE-2023-48631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48631/
Summaries are generated and may contain mistakes; the official description above is the record.
