CVE-2023-48649 Concrete CMS Cross-site Scripting vulnerability

Low 3.5 Published Updated

Attackers can execute arbitrary scripts in admin sessions by uploading files with malicious names, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-48649?

CVE-2023-48649 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 17 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Concrete CMS before 8.5.13 and 9.x before 9.2.2 allows stored XSS on the Admin page via an uploaded file name.

Weakness: CWE-79

Which versions are affected by CVE-2023-48649?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions8.5.13
concrete5/concrete5 PackagistAll versions8.5.13
concrete5/concrete5 PackagistFrom 9.0.09.2.2
concrete5/concrete5 PackagistFrom 9.0.09.2.2

Products include Concretecms Concrete Cms.

How do I fix CVE-2023-48649?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.13 or 9.2.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-48649 being exploited?

There is no known exploitation of CVE-2023-48649 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-36fr-3wg8-q5v8.

Is CVE-2023-48649 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free