CVE-2023-48650 Concrete CMS Stored XSS in Layout Preset Name

Medium 4.8 Published Updated

An admin can inject stored XSS payloads via Layout Preset names, potentially leading to code execution or account takeover in Concrete CMS.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-48650?

CVE-2023-48650 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 25 Dec 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Concrete CMS before 8.5.14 and 9 before 9.2.3 is vulnerable to an admin adding a stored XSS payload via the Layout Preset name.

Weakness: CWE-79

Which versions are affected by CVE-2023-48650?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions8.5.14
concrete5/concrete5 PackagistAll versions8.5.14
concrete5/concrete5 PackagistFrom 9.0.09.2.3
concrete5/concrete5 PackagistFrom 9.0.09.2.3

Products include Concretecms Concrete Cms.

How do I fix CVE-2023-48650?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.14 or 9.2.3.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-48650 being exploited?

There is no known exploitation of CVE-2023-48650 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-x577-gcc9-9xjj.

Is CVE-2023-48650 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free