{"answers":{"affected":"2 open source packages ship an affected version, including fastbots. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-48699 in the wild and no public exploit code.","fix":"Upgrade fastbots to 0.1.5 or later.","what":"CVE-2023-48699 is a high-severity code injection vulnerability in ubertidavide fastbots, published on 21 Nov 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-48699 and fix it if it is affected.\n\nWhat it is: CVE-2023-48699 is a high-severity code injection vulnerability in ubertidavide fastbots, published on 21 Nov 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-48699 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fastbots (PyPI): affected all versions; fixed in 0.1.5\n- fastbots (PyPI): affected all versions; fixed in 0.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-48699/ (Markdown: https://insights.sbomify.com/CVE-2023-48699/index.md)","id":"CVE-2023-48699","markdown":"https://insights.sbomify.com/CVE-2023-48699/index.md","name":"CVE-2023-48699","record":{"aliases":["GHSA-vccg-f4gp-45x9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python bot library","requires_auth":"none","summary":"An attacker can achieve remote code execution by injecting Python code into the locators.ini file processed by the fastbots library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fastbots","vendor":"ubertidavide"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"fastbots is a library for fast bot and scraper development using selenium and the Page Object Model (POM) design. Prior to version 0.1.5, an attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function `def __locator__(self, locator_name: str)` in `page.py`. In order to mitigate this issue, upgrade to fastbots version 0.1.5 or above.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"fastbots Eval Injection vulnerability","id":"CVE-2023-48699","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Clear Text Credentials Exposed via Onboarding Task","id":"CVE-2023-48700"},"packages":[{"ecosystem":"PyPI","fixed":["0.1.5"],"introduced":["0"],"last_affected":[],"package":"fastbots","purl":null,"source":"GHSA-vccg-f4gp-45x9"},{"ecosystem":"PyPI","fixed":["0.1.5"],"introduced":["0"],"last_affected":[],"package":"fastbots","purl":"pkg:pypi/fastbots","source":"GHSA-vccg-f4gp-45x9"}],"prev":{"headline":"Azure RTOS USBX Remote Code Execution Vulnerability","id":"CVE-2023-48698"},"products":["fastbots"],"published":"2023-11-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["ubertidavide"]},"summary":"An attacker can achieve remote code execution by injecting Python code into the locators.ini file processed by the fastbots library.","url":"https://insights.sbomify.com/CVE-2023-48699/"}