# CVE-2023-48699: fastbots Eval Injection vulnerability

> An attacker can achieve remote code execution by injecting Python code into the locators.ini file processed by the fastbots library.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-vccg-f4gp-45x9

## What is CVE-2023-48699?

CVE-2023-48699 is a high-severity code injection vulnerability in ubertidavide fastbots, published on 21 Nov 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

fastbots is a library for fast bot and scraper development using selenium and the Page Object Model (POM) design. Prior to version 0.1.5, an attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function `def __locator__(self, locator_name: str)` in `page.py`. In order to mitigate this issue, upgrade to fastbots version 0.1.5 or above.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2023-48699?

2 open source packages ship an affected version, including fastbots. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastbots` | PyPI | All versions | 0.1.5 |
| `fastbots` | PyPI | All versions | 0.1.5 |

Products: Ubertidavide Fastbots.

## How do I fix CVE-2023-48699?

Upgrade fastbots to 0.1.5 or later.

## Is CVE-2023-48699 being exploited?

There is no known exploitation of CVE-2023-48699 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48699 and fix it if it is affected.

What it is: CVE-2023-48699 is a high-severity code injection vulnerability in ubertidavide fastbots, published on 21 Nov 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-48699 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastbots (PyPI): affected all versions; fixed in 0.1.5
- fastbots (PyPI): affected all versions; fixed in 0.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48699/ (Markdown: https://insights.sbomify.com/CVE-2023-48699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48699
- OSV: https://osv.dev/vulnerability/CVE-2023-48699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48699/
Summaries are generated and may contain mistakes; the official description above is the record.
