{"answers":{"affected":"2 open source packages ship an affected version, including google-translate-api-browser. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-48711 in the wild and no public exploit code.","fix":"Upgrade google-translate-api-browser to 4.1.0 or later.","what":"CVE-2023-48711 is a low-severity server-side request forgery vulnerability in cjvnjde google-translate-api-browser, published on 24 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-48711 and fix it if it is affected.\n\nWhat it is: CVE-2023-48711 is a low-severity server-side request forgery vulnerability in cjvnjde google-translate-api-browser, published on 24 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-48711 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- google-translate-api-browser (npm): affected all versions; fixed in 4.1.0\n- google-translate-api-browser (npm): affected all versions; fixed in 4.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-48711/ (Markdown: https://insights.sbomify.com/CVE-2023-48711/index.md)","id":"CVE-2023-48711","markdown":"https://insights.sbomify.com/CVE-2023-48711/index.md","name":"CVE-2023-48711","record":{"aliases":["GHSA-4233-7q5q-m7p6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"npm translation library","requires_auth":"none","summary":"Attackers can exploit unsanitized input to force the library to make requests to internal network resources, potentially leading to data exposure or further exploitation.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"google_translate_api_browser","vendor":"cjvnjde"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"google-translate-api-browser is an npm package which interfaces with the google translate web api. A Server-Side Request Forgery (SSRF) Vulnerability is present in applications utilizing the `google-translate-api-browser` package and exposing the `translateOptions` to the end user. An attacker can set a malicious `tld`, causing the application to return unsafe URLs pointing towards local resources. The `translateOptions.tld` field is not properly sanitized before being placed in the Google translate URL. This can allow an attacker with control over the `translateOptions` to set the `tld` to a payload such as `@127.0.0.1`. This causes the full URL to become `https://translate.google.@127.0.0.1/...`, where `translate.google.` is the username used to connect to localhost. An attacker can send requests within internal networks and the local host. Should any HTTPS application be present on the internal network with a vulnerability exploitable via a GET call, then it would be possible to exploit this using this vulnerability. This issue has been addressed in release version 4.1.3. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Server-Side Request Forgery (SSRF) Vulnerability in google-translate-api-browser","id":"CVE-2023-48711","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"User authorization bug leading to privilege escalation in warpgate","id":"CVE-2023-48712"},"packages":[{"ecosystem":"npm","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"google-translate-api-browser","purl":null,"source":"GHSA-4233-7q5q-m7p6"},{"ecosystem":"npm","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"google-translate-api-browser","purl":"pkg:npm/google-translate-api-browser","source":"GHSA-4233-7q5q-m7p6"}],"prev":{"headline":"iTop limit pages/exec.php script to PHP files","id":"CVE-2023-48710"},"products":["google-translate-api-browser"],"published":"2023-11-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["cjvnjde"]},"summary":"Attackers can exploit unsanitized input to force the library to make requests to internal network resources, potentially leading to data exposure or further exploitation.","url":"https://insights.sbomify.com/CVE-2023-48711/"}